aboutsummaryrefslogtreecommitdiffstats
path: root/package/hostapd/Makefile
diff options
context:
space:
mode:
authorMichael Büsch <mb@bu3sch.de>2008-02-16 18:51:55 +0000
committerMichael Büsch <mb@bu3sch.de>2008-02-16 18:51:55 +0000
commit794ddf6b63a96b9cb8b573b94933f877d57b73bb (patch)
treeb8e4cc7f1123e0a4f3959677544c79f33f9df420 /package/hostapd/Makefile
parent939ceadf76a8303ada4994757268a8bf6b163f2a (diff)
downloadupstream-794ddf6b63a96b9cb8b573b94933f877d57b73bb.tar.gz
upstream-794ddf6b63a96b9cb8b573b94933f877d57b73bb.tar.bz2
upstream-794ddf6b63a96b9cb8b573b94933f877d57b73bb.zip
Add hostapd support for nl80211 (mac80211 stack)
SVN-Revision: 10469
Diffstat (limited to 'package/hostapd/Makefile')
-rw-r--r--package/hostapd/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/package/hostapd/Makefile b/package/hostapd/Makefile
index f196828c97..e38887cf7a 100644
--- a/package/hostapd/Makefile
+++ b/package/hostapd/Makefile
@@ -77,6 +77,11 @@ define Build/ConfigureTarget
$(PKG_BUILD_DIR)/hostapd \
$(PKG_BUILD_DIR)/src \
$(PKG_BUILD_DIR)/hostapd.$(1)/
+ $(CP) ./files/driver_nl80211.c $(PKG_BUILD_DIR)/hostapd.$(1)/hostapd/
+ $(CP) ./files/radiotap.c $(PKG_BUILD_DIR)/hostapd.$(1)/hostapd/
+ $(CP) ./files/radiotap.h $(PKG_BUILD_DIR)/hostapd.$(1)/hostapd/
+ $(CP) ./files/radiotap_iter.h $(PKG_BUILD_DIR)/hostapd.$(1)/hostapd/
+
$(CP) ./files/$(1).config $(PKG_BUILD_DIR)/hostapd.$(1)/hostapd/.config
$(if $(CONFIG_PACKAGE_kmod-mac80211),,$(SED) 's,^CONFIG_DRIVER_DEVICESCAPE,#CONFIG_DRIVER_DEVICESCAPE,g' $(PKG_BUILD_DIR)/hostapd.$(1)/hostapd/.config)
$(if $(CONFIG_PACKAGE_kmod-madwifi),,$(SED) 's,^CONFIG_DRIVER_MADWIFI,#CONFIG_DRIVER_MADWIFI,g' $(PKG_BUILD_DIR)/hostapd.$(1)/hostapd/.config)