aboutsummaryrefslogtreecommitdiffstats
path: root/package/hostapd/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2010-07-08 18:36:17 +0000
committerFelix Fietkau <nbd@openwrt.org>2010-07-08 18:36:17 +0000
commitca4a8b1bee22646319f8e2aeb1ed59062403a9b8 (patch)
treea564e331397dba07eb504951ab54088430a48d9c /package/hostapd/Makefile
parent3e75044a95d42c948dc84d4a88776c7923c20055 (diff)
downloadupstream-ca4a8b1bee22646319f8e2aeb1ed59062403a9b8.tar.gz
upstream-ca4a8b1bee22646319f8e2aeb1ed59062403a9b8.tar.bz2
upstream-ca4a8b1bee22646319f8e2aeb1ed59062403a9b8.zip
hostapd: add preliminary wps script support (push-button only, does not handle multi-bss yet)
SVN-Revision: 22100
Diffstat (limited to 'package/hostapd/Makefile')
-rw-r--r--package/hostapd/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/hostapd/Makefile b/package/hostapd/Makefile
index 4189922561..dcbe9e53a6 100644
--- a/package/hostapd/Makefile
+++ b/package/hostapd/Makefile
@@ -294,8 +294,9 @@ Package/hostapd-mini/install = $(Package/hostapd/install)
ifneq ($(LOCAL_TYPE),supplicant)
define Package/hostapd-utils/install
- $(INSTALL_DIR) $(1)/usr/sbin
+ $(INSTALL_DIR) $(1)/usr/sbin $(1)/etc/hotplug.d/button
$(INSTALL_BIN) $(PKG_BUILD_DIR)/hostapd/hostapd_cli $(1)/usr/sbin/
+ $(INSTALL_DATA) ./files/wps-hotplug.sh $(1)/etc/hotplug.d/button/50-wps
endef
endif