aboutsummaryrefslogtreecommitdiffstats
path: root/package/hostapd
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2007-03-28 00:35:26 +0000
committerNicolas Thill <nico@openwrt.org>2007-03-28 00:35:26 +0000
commit7f409744a44fcc7b7935d6c5f590a9c454ea7197 (patch)
tree7d629c11a99fc5c47080bf9dc7c7f54d0754f18a /package/hostapd
parent32490cac266799b368d73382af609b3625574c9b (diff)
downloadupstream-7f409744a44fcc7b7935d6c5f590a9c454ea7197.tar.gz
upstream-7f409744a44fcc7b7935d6c5f590a9c454ea7197.tar.bz2
upstream-7f409744a44fcc7b7935d6c5f590a9c454ea7197.zip
replace common -I and -L search flags with TARGET_CPPFLAGS and TARGET_LDFLAGS
SVN-Revision: 6735
Diffstat (limited to 'package/hostapd')
-rw-r--r--package/hostapd/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/hostapd/Makefile b/package/hostapd/Makefile
index d200822e89..b77873c3ce 100644
--- a/package/hostapd/Makefile
+++ b/package/hostapd/Makefile
@@ -70,8 +70,8 @@ define Build/CompileTarget
$(MAKE) -C $(PKG_BUILD_DIR)_$(1) \
$(TARGET_CONFIGURE_OPTS) \
OPTFLAGS="$(TARGET_CFLAGS)" \
- CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include -I$(STAGING_DIR)/usr/include/madwifi" \
- LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
+ CPPFLAGS="$(TARGET_CPPFLAGS) -I$(STAGING_DIR)/usr/include/madwifi" \
+ LDFLAGS="$(TARGET_LDFLAGS)" \
hostapd hostapd_cli
$(CP) $(PKG_BUILD_DIR)_$(1)/hostapd_cli $(PKG_BUILD_DIR)/
endef