aboutsummaryrefslogtreecommitdiffstats
path: root/package/hostapd
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-04-18 12:40:27 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-04-18 12:40:27 +0000
commitd913bf3c4976517d338be7220c65f8f03980bf6d (patch)
treea935e494a4cd4a4b705e9ad59cd67c7fc485db50 /package/hostapd
parent38515a7f8149704dd5903e35c568af8121a27e1e (diff)
downloadupstream-d913bf3c4976517d338be7220c65f8f03980bf6d.tar.gz
upstream-d913bf3c4976517d338be7220c65f8f03980bf6d.tar.bz2
upstream-d913bf3c4976517d338be7220c65f8f03980bf6d.zip
move hostapd setup script from wireless-tools to hostapd package
SVN-Revision: 7000
Diffstat (limited to 'package/hostapd')
-rw-r--r--package/hostapd/Makefile2
-rw-r--r--package/hostapd/files/hostapd.sh66
2 files changed, 68 insertions, 0 deletions
diff --git a/package/hostapd/Makefile b/package/hostapd/Makefile
index b77873c3ce..e500b87bd0 100644
--- a/package/hostapd/Makefile
+++ b/package/hostapd/Makefile
@@ -81,6 +81,8 @@ define Package/InstallTemplate
rm -f $(PKG_BUILD_DIR)/.built; \
$(MAKE) $(PKG_BUILD_DIR)/.built; \
fi
+ $(INSTALL_DIR) $$(1)/lib/wifi
+ $(INSTALL_DATA) ./files/hostapd.sh $$(1)/lib/wifi/hostapd.sh
$(INSTALL_DIR) $$(1)/etc
$(INSTALL_CONF) $(PKG_BUILD_DIR)_$(2)/madwifi.conf $$(1)/etc/hostapd.conf
$(INSTALL_DIR) $$(1)/usr/sbin
diff --git a/package/hostapd/files/hostapd.sh b/package/hostapd/files/hostapd.sh
new file mode 100644
index 0000000000..529462e6c9
--- /dev/null
+++ b/package/hostapd/files/hostapd.sh
@@ -0,0 +1,66 @@
+hostapd_setup_vif() {
+ local vif="$1"
+ local driver="$2"
+ local hostapd_cfg=
+
+ # Examples:
+ # psk-mixed/tkip => WPA1+2 PSK, TKIP
+ # wpa-psk2/tkip+aes => WPA2 PSK, CCMP+TKIP
+ # wpa2/tkip+aes => WPA2 RADIUS, CCMP+TKIP
+ # ...
+
+ # TODO: move this parsing function somewhere generic, so that
+ # later it can be reused by drivers that don't use hostapd
+
+ # crypto defaults: WPA2 vs WPA1
+ case "$enc" in
+ wpa2*|WPA2*|*PSK2*|*psk2*)
+ wpa=2
+ crypto="CCMP"
+ ;;
+ *mixed*)
+ wpa=3
+ crypto="CCMP TKIP"
+ ;;
+ *)
+ wpa=1
+ crypto="TKIP"
+ ;;
+ esac
+
+ # explicit override for crypto setting
+ case "$enc" in
+ *tkip+aes|*TKIP+AES|*tkip+ccmp|*TKIP+CCMP) crypto="CCMP TKIP";;
+ *tkip|*TKIP) crypto="TKIP";;
+ *aes|*AES|*ccmp|*CCMP) crypto="CCMP";;
+ esac
+
+ # use crypto/auth settings for building the hostapd config
+ case "$enc" in
+ *psk*|*PSK*)
+ config_get psk "$vif" key
+ append hostapd_cfg "wpa_passphrase=$psk" "$N"
+ ;;
+ *wpa*|*WPA*)
+ # FIXME: add wpa+radius here
+ ;;
+ *)
+ return 0;
+ ;;
+ esac
+ config_get ifname "$vif" ifname
+ config_get bridge "$vif" bridge
+ config_get ssid "$vif" ssid
+ cat > /var/run/hostapd-$ifname.conf <<EOF
+driver=$driver
+interface=$ifname
+${bridge:+bridge=$bridge}
+ssid=$ssid
+debug=0
+wpa=$wpa
+wpa_pairwise=$crypto
+$hostapd_cfg
+EOF
+ hostapd -B /var/run/hostapd-$ifname.conf
+}
+