aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/lantiq/ltq-adsl-fw
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-04-14 16:10:49 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-04-24 17:59:22 +0200
commitd8b3f53f5e1fe13d2468feff94f4a1f8e53ba53a (patch)
treefe58c11b822cd48c305f4f16aa066983071fd5d3 /package/kernel/lantiq/ltq-adsl-fw
parentd3c9630811468499a94302fc57f3a4874f1614bc (diff)
downloadupstream-d8b3f53f5e1fe13d2468feff94f4a1f8e53ba53a.tar.gz
upstream-d8b3f53f5e1fe13d2468feff94f4a1f8e53ba53a.tar.bz2
upstream-d8b3f53f5e1fe13d2468feff94f4a1f8e53ba53a.zip
ltq-adsl(-fw): Makefile clean-up and fixes
This fixes a few minor issues (partially cosmetic) in ltq-adsl and ltq-adsl-fw Makefiles: - fix PKG_SOURCE_URL and switch to https - remove non-existant FW_NAME variable - fix package name for config inclusion - fix config symbol for debugging Fixes: 1d0a9d0c0470 ("move ltq-adsl") Cc: John Crispin <john@phrozen.org> Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'package/kernel/lantiq/ltq-adsl-fw')
-rw-r--r--package/kernel/lantiq/ltq-adsl-fw/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/kernel/lantiq/ltq-adsl-fw/Makefile b/package/kernel/lantiq/ltq-adsl-fw/Makefile
index 5775d0cf50..66f91a991e 100644
--- a/package/kernel/lantiq/ltq-adsl-fw/Makefile
+++ b/package/kernel/lantiq/ltq-adsl-fw/Makefile
@@ -13,7 +13,7 @@ PKG_RELEASE:=1
PKG_BUILD_DIR:=$(BUILD_DIR)/ltq-dsl-fw-$(PKG_VERSION)
PKG_SOURCE:=ltq-dsl-fw-$(PKG_VERSION).tar.bz2
-PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources/
+PKG_SOURCE_URL:=https://sources.openwrt.org/
PKG_HASH:=28676d41c4b76e5bf7a2c5eae106a61fb96b93eabc0cb71120575fff9997269f
PKG_MAINTAINER:=John Crispin <john@phrozen.org>
@@ -45,8 +45,8 @@ endef
define Package/kmod-ltq-adsl-$(BUILD_VARIANT)/install
$(INSTALL_DIR) $(1)/lib/firmware/
- $(CP) $(PKG_BUILD_DIR)/$(FW_NAME)/ltq-dsl-fw-$(ANNEX)-$(SOC).bin $(1)/lib/firmware/
- ln -s /lib/firmware/$(FW_NAME)/ltq-dsl-fw-$(ANNEX)-$(SOC).bin $(1)/lib/firmware/adsl.bin
+ $(CP) $(PKG_BUILD_DIR)/ltq-dsl-fw-$(ANNEX)-$(SOC).bin $(1)/lib/firmware/
+ ln -s /lib/firmware/ltq-dsl-fw-$(ANNEX)-$(SOC).bin $(1)/lib/firmware/adsl.bin
endef
$(eval $(call BuildPackage,kmod-ltq-adsl-danube-fw-a))