aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/lantiq/ltq-vdsl-mei/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-11-24 20:40:59 +0000
committerJohn Crispin <john@openwrt.org>2015-11-24 20:40:59 +0000
commit5d236c4dd0f83261eebe76499636c676d5e26152 (patch)
treebc3ac508ac9f3415d5c7f6b4f7a4a95d725c942e /package/kernel/lantiq/ltq-vdsl-mei/Makefile
parentca541cffd09340d5f2ee2d95efce079b3a581b29 (diff)
downloadupstream-5d236c4dd0f83261eebe76499636c676d5e26152.tar.gz
upstream-5d236c4dd0f83261eebe76499636c676d5e26152.tar.bz2
upstream-5d236c4dd0f83261eebe76499636c676d5e26152.zip
lantiq: ltq-vdsl-mei: update to version 1.4.8.5
In addition to the update this also fixes some build warnings and makes it use the same configure option as used in Lantiq UGW. Signed-off-by: Hauke Mehrtens <hauke.mehrtens@lantiq.com> SVN-Revision: 47634
Diffstat (limited to 'package/kernel/lantiq/ltq-vdsl-mei/Makefile')
-rw-r--r--package/kernel/lantiq/ltq-vdsl-mei/Makefile12
1 files changed, 5 insertions, 7 deletions
diff --git a/package/kernel/lantiq/ltq-vdsl-mei/Makefile b/package/kernel/lantiq/ltq-vdsl-mei/Makefile
index 3a2d572aa7..5ff1321483 100644
--- a/package/kernel/lantiq/ltq-vdsl-mei/Makefile
+++ b/package/kernel/lantiq/ltq-vdsl-mei/Makefile
@@ -1,4 +1,5 @@
# Copyright (C) 2012 OpenWrt.org
+# Copyright (C) 2015 Lantiq Beteiligungs GmbH & Co KG.
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -7,14 +8,14 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=ltq-vdsl-vr9-mei
-PKG_VERSION:=1.4.8.4
+PKG_VERSION:=1.4.8.5
PKG_RELEASE:=1
PKG_BASE_NAME:=drv_mei_cpe
PKG_SOURCE:=$(PKG_BASE_NAME)-$(PKG_VERSION).tar.gz
PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_BASE_NAME)-$(PKG_VERSION)
-PKG_SOURCE_URL:=https://github.com/xdarklight/$(PKG_BASE_NAME)/archive/v$(PKG_VERSION)
-PKG_MD5SUM:=30570722dc7f19ff2f0228838043f2a2
+PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
+PKG_MD5SUM:=78bf61dbc3421123c6716b874a930759
PKG_FIXUP:=autoreconf
PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
PKG_USE_MIPS16:=0
@@ -49,9 +50,6 @@ define Package/ltq-vdsl-mei_test/description
for test and development purposes.
endef
-
-#DEBUG=-DDEBUG_PRINT=1
-
MAKE_FLAGS += \
SHELL="$(BASH)"
@@ -64,7 +62,7 @@ CONFIGURE_ARGS += \
--enable-error_print \
--enable-ifxos-include="-I$(STAGING_DIR)/usr/include/ifxos/" \
--enable-ifxos-library="-L$(STAGING_DIR)/usr/lib" \
- --enable-add_drv_cflags="$(DEBUG) -DMEI_DRV_ATM_PTM_INTERFACE_ENABLE=1 -DMEI_EXPORT_INTERNAL_API=1 -DMEI_SUPPORT_DSM=0 -fno-pic -mno-abicalls -mlong-calls -O2 -g0" \
+ --enable-add_drv_cflags="-DMEI_SUPPORT_DSM=0 -DMEI_DRV_ATM_PTM_INTERFACE_ENABLE=1 -fno-pic -mlong-calls -O2 -g0" \
--enable-linux-26 \
--enable-kernelbuild="$(LINUX_DIR)" \
--enable-drv_test_appl=yes \