aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/other.mk
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-01-24 20:02:09 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-01-24 20:02:09 +0000
commit3120c9c9c24e3e80e646cdac2f75875e2e6a91fe (patch)
treee026e700f612c982bc2622df0d8c5dc6c78411d7 /package/kernel/linux/modules/other.mk
parent186db26d05034df31e0ced1b8b5d7d62ebe39b8f (diff)
downloadupstream-3120c9c9c24e3e80e646cdac2f75875e2e6a91fe.tar.gz
upstream-3120c9c9c24e3e80e646cdac2f75875e2e6a91fe.tar.bz2
upstream-3120c9c9c24e3e80e646cdac2f75875e2e6a91fe.zip
build: drop obsolete kernel version dependencies
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 44110
Diffstat (limited to 'package/kernel/linux/modules/other.mk')
-rw-r--r--package/kernel/linux/modules/other.mk9
1 files changed, 4 insertions, 5 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 70acf54727..decc1df675 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -13,7 +13,7 @@ WATCHDOG_DIR:=watchdog
define KernelPackage/6lowpan-iphc
USBMENU:=$(OTHER_MENU)
TITLE:=6lowpan shared code
- DEPENDS:=@!LINUX_3_3 @!LINUX_3_8 @!LINUX_3_10 @!LINUX_3_13
+ DEPENDS:=@!LINUX_3_8 @!LINUX_3_10 @!LINUX_3_13
KCONFIG:=CONFIG_6LOWPAN_IPHC
HIDDEN:=1
FILES:=$(LINUX_DIR)/net/ieee802154/6lowpan_iphc.ko
@@ -29,7 +29,7 @@ $(eval $(call KernelPackage,6lowpan-iphc))
define KernelPackage/bluetooth
SUBMENU:=$(OTHER_MENU)
TITLE:=Bluetooth support
- DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-crypto-hash +(!LINUX_3_3&&!LINUX_3_8&&!LINUX_3_10&&!LINUX_3_13):kmod-6lowpan-iphc
+ DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-crypto-hash +(!LINUX_3_8&&!LINUX_3_10&&!LINUX_3_13):kmod-6lowpan-iphc
KCONFIG:= \
CONFIG_BLUEZ \
CONFIG_BLUEZ_L2CAP \
@@ -73,7 +73,7 @@ $(eval $(call KernelPackage,bluetooth))
define KernelPackage/bluetooth_6lowpan
SUBMENU:=$(OTHER_MENU)
TITLE:=Bluetooth 6LoWPAN support
- DEPENDS:=+kmod-bluetooth @!(LINUX_3_3||LINUX_3_8||LINUX_3_10||LINUX_3_13||LINUX_3_14)
+ DEPENDS:=+kmod-bluetooth @!(LINUX_3_8||LINUX_3_10||LINUX_3_13||LINUX_3_14)
KCONFIG:= \
CONFIG_6LOWPAN=m \
CONFIG_BT_6LOWPAN=m
@@ -231,7 +231,6 @@ $(eval $(call KernelPackage,gpio-pcf857x))
define KernelPackage/iio-core
SUBMENU:=$(OTHER_MENU)
- DEPENDS:=@!LINUX_3_3 @!LINUX_3_6
TITLE:=Industrial IO core
KCONFIG:= \
CONFIG_IIO \
@@ -749,7 +748,7 @@ $(eval $(call KernelPackage,ikconfig))
define KernelPackage/zram
SUBMENU:=$(OTHER_MENU)
TITLE:=ZRAM
- DEPENDS:=@!LINUX_3_3 +kmod-lib-lzo
+ DEPENDS:=+kmod-lib-lzo
KCONFIG:= \
CONFIG_ZSMALLOC \
CONFIG_ZRAM \