aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/linux/modules/other.mk
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-08-07 14:21:10 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-09-02 16:29:23 +0200
commit6362a04725b859ac306e54359b14ea2612af28db (patch)
treedfa47aa0d42c3cde0f810133206da4bf36de8e66 /package/kernel/linux/modules/other.mk
parent95acc4fe0e31ae91d485635c021d259e06785b5d (diff)
downloadupstream-6362a04725b859ac306e54359b14ea2612af28db.tar.gz
upstream-6362a04725b859ac306e54359b14ea2612af28db.tar.bz2
upstream-6362a04725b859ac306e54359b14ea2612af28db.zip
kernel: remove obsolete kernel version switches for 4.14
This removes switches dependent on kernel version 4.14 as well as several packages/modules selected only for that version. This also removes sched-cake-virtual, which is not required anymore now that we have only one variant of cake. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'package/kernel/linux/modules/other.mk')
-rw-r--r--package/kernel/linux/modules/other.mk46
1 files changed, 7 insertions, 39 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 6eb9404837..ade5f13ee8 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -139,7 +139,7 @@ $(eval $(call KernelPackage,dma-buf))
define KernelPackage/nvmem
SUBMENU:=$(OTHER_MENU)
TITLE:=Non Volatile Memory support
- DEPENDS:=@!LINUX_5_4
+ DEPENDS:=@LINUX_4_19
KCONFIG:=CONFIG_NVMEM
HIDDEN:=1
FILES:=$(LINUX_DIR)/drivers/nvmem/nvmem_core.ko
@@ -170,7 +170,7 @@ define KernelPackage/eeprom-at24
SUBMENU:=$(OTHER_MENU)
TITLE:=EEPROM AT24 support
KCONFIG:=CONFIG_EEPROM_AT24
- DEPENDS:=+kmod-i2c-core +!LINUX_5_4:kmod-nvmem +!LINUX_4_14:kmod-regmap-i2c
+ DEPENDS:=+kmod-i2c-core +LINUX_4_19:kmod-nvmem +kmod-regmap-i2c
FILES:=$(LINUX_DIR)/drivers/misc/eeprom/at24.ko
AUTOLOAD:=$(call AutoProbe,at24)
endef
@@ -186,7 +186,7 @@ define KernelPackage/eeprom-at25
SUBMENU:=$(OTHER_MENU)
TITLE:=EEPROM AT25 support
KCONFIG:=CONFIG_EEPROM_AT25
- DEPENDS:=+!LINUX_5_4:kmod-nvmem
+ DEPENDS:=+LINUX_4_19:kmod-nvmem
FILES:=$(LINUX_DIR)/drivers/misc/eeprom/at25.ko
AUTOLOAD:=$(call AutoProbe,at25)
endef
@@ -265,7 +265,7 @@ $(eval $(call KernelPackage,gpio-nxp-74hc164))
define KernelPackage/gpio-pca953x
SUBMENU:=$(OTHER_MENU)
- DEPENDS:=@GPIO_SUPPORT +kmod-i2c-core +LINUX_5_4:kmod-regmap-i2c
+ DEPENDS:=@GPIO_SUPPORT +kmod-i2c-core +!LINUX_4_19:kmod-regmap-i2c
TITLE:=PCA95xx, TCA64xx, and MAX7310 I/O ports
KCONFIG:=CONFIG_GPIO_PCA953X
FILES:=$(LINUX_DIR)/drivers/gpio/gpio-pca953x.ko
@@ -651,7 +651,7 @@ define KernelPackage/rtc-pcf2123
SUBMENU:=$(OTHER_MENU)
TITLE:=Philips PCF2123 RTC support
DEFAULT:=m if ALL_KMODS && RTC_SUPPORT
- DEPENDS:=+LINUX_5_4:kmod-regmap-spi
+ DEPENDS:=+!LINUX_4_19:kmod-regmap-spi
KCONFIG:=CONFIG_RTC_DRV_PCF2123 \
CONFIG_RTC_CLASS=y
FILES:=$(LINUX_DIR)/drivers/rtc/rtc-pcf2123.ko
@@ -1022,26 +1022,10 @@ endef
$(eval $(call KernelPackage,ptp))
-define KernelPackage/ptp-gianfar
- SUBMENU:=$(OTHER_MENU)
- TITLE:=Freescale Gianfar PTP support
- DEPENDS:=@TARGET_mpc85xx +kmod-ptp @LINUX_4_14
- KCONFIG:=CONFIG_PTP_1588_CLOCK_GIANFAR
- FILES:=$(LINUX_DIR)/drivers/net/ethernet/freescale/gianfar_ptp.ko
- AUTOLOAD:=$(call AutoProbe,gianfar_ptp)
-endef
-
-define KernelPackage/ptp-gianfar/description
- Kernel module for IEEE 1588 support for Freescale
- Gianfar Ethernet drivers
-endef
-
-$(eval $(call KernelPackage,ptp-gianfar))
-
define KernelPackage/ptp-qoriq
SUBMENU:=$(OTHER_MENU)
TITLE:=Freescale QorIQ PTP support
- DEPENDS:=@TARGET_mpc85xx +kmod-ptp @!LINUX_4_14
+ DEPENDS:=@TARGET_mpc85xx +kmod-ptp
KCONFIG:=CONFIG_PTP_1588_CLOCK_QORIQ
FILES:=$(LINUX_DIR)/drivers/ptp/ptp-qoriq.ko
AUTOLOAD:=$(call AutoProbe,ptp-qoriq)
@@ -1069,22 +1053,6 @@ endef
$(eval $(call KernelPackage,random-core))
-define KernelPackage/random-tpm
- SUBMENU:=$(OTHER_MENU)
- TITLE:=Hardware Random Number Generator TPM support
- KCONFIG:=CONFIG_HW_RANDOM_TPM
- FILES:=$(LINUX_DIR)/drivers/char/hw_random/tpm-rng.ko
- DEPENDS:= +kmod-random-core +kmod-tpm @LINUX_4_14
- AUTOLOAD:=$(call AutoProbe,tpm-rng)
-endef
-
-define KernelPackage/random-tpm/description
- Kernel module for the Random Number Generator
- in the Trusted Platform Module.
-endef
-
-$(eval $(call KernelPackage,random-tpm))
-
define KernelPackage/thermal
SUBMENU:=$(OTHER_MENU)
TITLE:=Generic Thermal sysfs driver
@@ -1201,7 +1169,7 @@ $(eval $(call KernelPackage,bmp085-spi))
define KernelPackage/tpm
SUBMENU:=$(OTHER_MENU)
TITLE:=TPM Hardware Support
- DEPENDS:= +!LINUX_4_14:kmod-random-core
+ DEPENDS:= +kmod-random-core
KCONFIG:= CONFIG_TCG_TPM
FILES:= $(LINUX_DIR)/drivers/char/tpm/tpm.ko
AUTOLOAD:=$(call AutoLoad,10,tpm,1)