aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/modules/001-depends.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2012-10-17 22:46:16 +0000
committerJohn Crispin <john@openwrt.org>2012-10-17 22:46:16 +0000
commit01ccf0225bf0df785e2798f02359926a6c4ce9e5 (patch)
tree9f4cd09fef4f3a2e2d2b7cf1db315e678a2d6210 /package/kernel/modules/001-depends.mk
parenta34499e09569241a21203c1327f3bfa8a888584f (diff)
downloadupstream-01ccf0225bf0df785e2798f02359926a6c4ce9e5.tar.gz
upstream-01ccf0225bf0df785e2798f02359926a6c4ce9e5.tar.bz2
upstream-01ccf0225bf0df785e2798f02359926a6c4ce9e5.zip
ixp4xx/cns3xxx: add rfkill module support
Both ixp4xx and cns3xxx targets support RFKILL in the kernel. Also add a RFKILL_GPIO default for kernel config Signed-off-by: Tim Harvey <tharvey@gateworks.com> SVN-Revision: 33831
Diffstat (limited to 'package/kernel/modules/001-depends.mk')
-rw-r--r--package/kernel/modules/001-depends.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/kernel/modules/001-depends.mk b/package/kernel/modules/001-depends.mk
index 6c493018df..e0af735705 100644
--- a/package/kernel/modules/001-depends.mk
+++ b/package/kernel/modules/001-depends.mk
@@ -24,11 +24,11 @@ endef
define SetDepends/rfkill
- DEPENDS:= @(TARGET_ar71xx||TARGET_brcm47xx||TARGET_s3c24xx||TARGET_x86||TARGET_gemini)
+ DEPENDS:= @(TARGET_ar71xx||TARGET_brcm47xx||TARGET_s3c24xx||TARGET_x86||TARGET_gemini||TARGET_cns3xxx||TARGET_ixp4xx)
endef
define AddDepends/rfkill
- DEPENDS+= +(TARGET_ar71xx||TARGET_brcm47xx||TARGET_s3c24xx||TARGET_x86):kmod-rfkill $(1)
+ DEPENDS+= +(TARGET_ar71xx||TARGET_brcm47xx||TARGET_s3c24xx||TARGET_x86||TARGET_cns3xxx||TARGET_ixp4xx):kmod-rfkill $(1)
endef