aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/modules/netsupport.mk
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2010-09-04 18:06:49 +0000
committerFlorian Fainelli <florian@openwrt.org>2010-09-04 18:06:49 +0000
commit573f15826d5e588ca2f57af0555036d9c4224206 (patch)
treee6684559d082a6d3fc51ea06807f89c60b7d82c6 /package/kernel/modules/netsupport.mk
parent54f4be5bd6f4e0abdac2edf72d0adc8ccde52c0f (diff)
downloadupstream-573f15826d5e588ca2f57af0555036d9c4224206.tar.gz
upstream-573f15826d5e588ca2f57af0555036d9c4224206.tar.bz2
upstream-573f15826d5e588ca2f57af0555036d9c4224206.zip
kmod-sctp: Add SCTP kernel support
This adds a new kmod-sctp option that enables support of SCTP in 2.6x kernels. The patch also contains a small cleanup in the dependencies. Signed-off-by: Sebastien Decugis <sdecugis@nict.go.jp> SVN-Revision: 22917
Diffstat (limited to 'package/kernel/modules/netsupport.mk')
-rw-r--r--package/kernel/modules/netsupport.mk22
1 files changed, 22 insertions, 0 deletions
diff --git a/package/kernel/modules/netsupport.mk b/package/kernel/modules/netsupport.mk
index 196e5a39c8..703cc648ca 100644
--- a/package/kernel/modules/netsupport.mk
+++ b/package/kernel/modules/netsupport.mk
@@ -674,3 +674,25 @@ endef
$(eval $(call KernelPackage,l2tp-ip))
+define KernelPackage/sctp
+ SUBMENU:=$(NETWORK_SUPPORT_MENU)
+ TITLE:=SCTP protocol kernel support
+ KCONFIG:=\
+ CONFIG_IP_SCTP \
+ CONFIG_SCTP_DBG_MSG=n \
+ CONFIG_SCTP_DBG_OBJCNT=n \
+ CONFIG_SCTP_HMAC_NONE=n \
+ CONFIG_SCTP_HMAC_SHA1=n \
+ CONFIG_SCTP_HMAC_MD5=y
+ FILES:= $(LINUX_DIR)/net/sctp/sctp.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:= $(call AutoLoad,32,sctp)
+ DEPENDS:=+kmod-libcrc32c +kmod-crypto-md5 +kmod-crypto-hmac
+endef
+
+define KernelPackage/sctp/description
+ Kernel modules for SCTP protocol support
+endef
+
+$(eval $(call KernelPackage,sctp))
+
+