aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/modules/other.mk
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2011-05-25 19:51:40 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2011-05-25 19:51:40 +0000
commit6769216a6490f7422294d3b5ae679403156ffbb5 (patch)
tree8f901ccb198669d2f29fc5826c6da9d5e4b9874b /package/kernel/modules/other.mk
parentc69f2d8788919032dd1046983eb820198571bc97 (diff)
downloadupstream-6769216a6490f7422294d3b5ae679403156ffbb5.tar.gz
upstream-6769216a6490f7422294d3b5ae679403156ffbb5.tar.bz2
upstream-6769216a6490f7422294d3b5ae679403156ffbb5.zip
kernel: generic: Update 2.6.39 to final
* Add missing config symbols * Update package/kernel for 2.6.39 CONFIG_BT_L2CAP=y and CONFIG_BT_SCO=y are set to build them into the bluetooth module. Thank you Jonas Gorski for the patch SVN-Revision: 27010
Diffstat (limited to 'package/kernel/modules/other.mk')
-rw-r--r--package/kernel/modules/other.mk11
1 files changed, 8 insertions, 3 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index 5ab43368ee..3e17dc345d 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -38,14 +38,19 @@ define KernelPackage/bluetooth
$(call AddDepends/rfkill)
FILES:= \
$(LINUX_DIR)/net/bluetooth/bluetooth.ko \
- $(LINUX_DIR)/net/bluetooth/l2cap.ko \
- $(LINUX_DIR)/net/bluetooth/sco.ko \
$(LINUX_DIR)/net/bluetooth/rfcomm/rfcomm.ko \
$(LINUX_DIR)/net/bluetooth/bnep/bnep.ko \
$(LINUX_DIR)/net/bluetooth/hidp/hidp.ko \
$(LINUX_DIR)/drivers/bluetooth/hci_uart.ko \
$(LINUX_DIR)/drivers/bluetooth/btusb.ko
- AUTOLOAD:=$(call AutoLoad,90,bluetooth l2cap sco rfcomm bnep hidp hci_uart btusb)
+ ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.39)),1)
+ AUTOLOAD:=$(call AutoLoad,90,bluetooth rfcomm bnep hidp hci_uart btusb)
+ else
+ FILES+= \
+ $(LINUX_DIR)/net/bluetooth/l2cap.ko \
+ $(LINUX_DIR)/net/bluetooth/sco.ko
+ AUTOLOAD:=$(call AutoLoad,90,bluetooth l2cap sco rfcomm bnep hidp hci_uart btusb)
+ endif
endef
define KernelPackage/bluetooth/description