aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/modules/pcmcia.mk
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2013-06-21 16:54:37 +0000
committerJohn Crispin <john@openwrt.org>2013-06-21 16:54:37 +0000
commit4ebf19b48fafc8d94e14e4ba779969613b241a6a (patch)
tree9918f890a8915023b49ea30948beb5d048c333fa /package/kernel/modules/pcmcia.mk
parent44b1688e6c7b4f16f7165fbd560e1183aef69090 (diff)
downloadupstream-4ebf19b48fafc8d94e14e4ba779969613b241a6a.tar.gz
upstream-4ebf19b48fafc8d94e14e4ba779969613b241a6a.tar.bz2
upstream-4ebf19b48fafc8d94e14e4ba779969613b241a6a.zip
packages: clean up the package folder
Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 37007
Diffstat (limited to 'package/kernel/modules/pcmcia.mk')
-rw-r--r--package/kernel/modules/pcmcia.mk80
1 files changed, 0 insertions, 80 deletions
diff --git a/package/kernel/modules/pcmcia.mk b/package/kernel/modules/pcmcia.mk
deleted file mode 100644
index cac727719c..0000000000
--- a/package/kernel/modules/pcmcia.mk
+++ /dev/null
@@ -1,80 +0,0 @@
-#
-# Copyright (C) 2006-2010 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-PCMCIA_MENU:=PCMCIA support
-
-define KernelPackage/pcmcia-core
- SUBMENU:=$(PCMCIA_MENU)
- TITLE:=PCMCIA/CardBus support
- DEPENDS:=@PCMCIA_SUPPORT
- KCONFIG:= \
- CONFIG_PCMCIA \
- CONFIG_CARDBUS \
- CONFIG_PCCARD \
- PCMCIA_DEBUG=n
- FILES:= \
- $(LINUX_DIR)/drivers/pcmcia/pcmcia_core.ko \
- $(LINUX_DIR)/drivers/pcmcia/pcmcia.ko
- AUTOLOAD:=$(call AutoLoad,25,pcmcia_core pcmcia)
-endef
-
-define KernelPackage/pcmcia-core/description
- Kernel support for PCMCIA/CardBus controllers
-endef
-
-$(eval $(call KernelPackage,pcmcia-core))
-
-define KernelPackage/pcmcia-rsrc
- SUBMENU:=$(PCMCIA_MENU)
- TITLE:=PCMCIA resource support
- DEPENDS:=kmod-pcmcia-core
- KCONFIG:=CONFIG_PCCARD_NONSTATIC=y
-# For Linux 2.6.35+
-ifneq ($(wildcard $(LINUX_DIR)/drivers/pcmcia/pcmcia_rsrc.ko),)
- FILES:=$(LINUX_DIR)/drivers/pcmcia/pcmcia_rsrc.ko
- AUTOLOAD:=$(call AutoLoad,26,pcmcia_rsrc)
-else
- FILES:=$(LINUX_DIR)/drivers/pcmcia/rsrc_nonstatic.ko
- AUTOLOAD:=$(call AutoLoad,26,rsrc_nonstatic)
-endif
-endef
-
-define KernelPackage/pcmcia-rsrc/description
- Kernel support for PCMCIA resource allocation
-endef
-
-$(eval $(call KernelPackage,pcmcia-rsrc))
-
-
-define KernelPackage/pcmcia-yenta
- SUBMENU:=$(PCMCIA_MENU)
- TITLE:=yenta socket driver
- DEPENDS:=kmod-pcmcia-rsrc
- KCONFIG:=CONFIG_YENTA
- FILES:=$(LINUX_DIR)/drivers/pcmcia/yenta_socket.ko
- AUTOLOAD:=$(call AutoLoad,41,pcmcia_rsrc yenta_socket)
-endef
-
-$(eval $(call KernelPackage,pcmcia-yenta))
-
-
-define KernelPackage/pcmcia-serial
- SUBMENU:=$(PCMCIA_MENU)
- TITLE:=Serial devices support
- DEPENDS:=kmod-pcmcia-core
- KCONFIG:= \
- CONFIG_PCMCIA_SERIAL_CS \
- CONFIG_SERIAL_8250_CS
- FILES:=$(LINUX_DIR)/drivers/tty/serial/8250/serial_cs.ko
- AUTOLOAD:=$(call AutoLoad,45,serial_cs)
-endef
-
-define KernelPackage/pcmcia-serial/description
- Kernel support for PCMCIA/CardBus serial devices
-endef
-
-$(eval $(call KernelPackage,pcmcia-serial))