aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/mt76
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2018-10-14 18:46:32 +0200
committerFelix Fietkau <nbd@nbd.name>2018-10-14 18:47:44 +0200
commit055fb0ba836d130f285b907a5c441f156fabbaba (patch)
treebed6e216297e867d618fb1b8e5482e3f038217d8 /package/kernel/mt76
parent759f111f8d7f2d9f5f12713fc6f48ce6422997ec (diff)
downloadupstream-055fb0ba836d130f285b907a5c441f156fabbaba.tar.gz
upstream-055fb0ba836d130f285b907a5c441f156fabbaba.tar.bz2
upstream-055fb0ba836d130f285b907a5c441f156fabbaba.zip
mt76: move mt76x2e firmware to kmod-mt76x2-common and use it for mt76x2u
USB and PCIe devices can run the same firmware Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/kernel/mt76')
-rw-r--r--package/kernel/mt76/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/package/kernel/mt76/Makefile b/package/kernel/mt76/Makefile
index a0b966c75a..5238b4c73c 100644
--- a/package/kernel/mt76/Makefile
+++ b/package/kernel/mt76/Makefile
@@ -183,7 +183,7 @@ define Package/kmod-mt76/install
true
endef
-define KernelPackage/mt76x2/install
+define KernelPackage/mt76x2-common/install
$(INSTALL_DIR) $(1)/lib/firmware
cp \
$(PKG_BUILD_DIR)/firmware/mt7662_rom_patch.bin \
@@ -191,6 +191,12 @@ define KernelPackage/mt76x2/install
$(1)/lib/firmware
endef
+define KernelPackage/mt76x2u/install
+ $(INSTALL_DIR) $(1)/lib/firmware/mediatek
+ ln -sf ../mt7662.bin $(1)/lib/firmware/mediatek/mt7662u.bin
+ ln -sf ../mt7662_rom_patch.bin $(1)/lib/firmware/mediatek/mt7662u_rom_patch.bin
+endef
+
define KernelPackage/mt7603/install
$(INSTALL_DIR) $(1)/lib/firmware
cp $(if $(CONFIG_TARGET_ramips_mt76x8), \