aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/mt76
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2018-10-02 13:00:39 +0200
committerFelix Fietkau <nbd@nbd.name>2018-10-06 13:02:29 +0200
commitd51cbefe86c230f708b9c766d6f6d2ffe5074215 (patch)
tree5ad7b9bff4dba0285cb988a69546e2fcd9fbacec /package/kernel/mt76
parent8c647e873f9adf4527e61684458075f8d2b61a97 (diff)
downloadupstream-d51cbefe86c230f708b9c766d6f6d2ffe5074215.tar.gz
upstream-d51cbefe86c230f708b9c766d6f6d2ffe5074215.tar.bz2
upstream-d51cbefe86c230f708b9c766d6f6d2ffe5074215.zip
mt76: update to the latest version
053de5c mt76x0: pci: add mt76x0e_cleanup routine c6b1926 mt76x2: move mt76x2 source files to mt76x2 folder 6afb1b8 mt76: fix header guard macro define names 05c7f24 mt76: fix frag length allocation for usb 6856ef6 mt76: usb: fix hw initialization sequence 3d43146 mt76x0: usb: stop cal/mac workqueues at hw stop bef08cc mt76: move mt76x02_tx_get_max_txpwr_adj in mt76x02_util.c cd42111 mt76: add get_tx_txpwr_adj function pointer to mt76_driver_ops c49a3ae mt76: move mt76x02_mac_write_txwi in mt76x02-lib module 4bae980 mt76: usb: use mt76x02u_tx_prepare_skb to fill txwi e0847b4 mt76x0: init: remove unnecessary configurations e802b5c mt76: move mt76x02_phy_get_min_avg_rssi in mt76x02_phy.c 2742847 mt76: move mt76x02_rx_get_sta and mt76x02_rx_get_sta_wcid in mt76x02_util.h c26f9fd mt76x0: mac: use sta ewma estimation for rssi tracking 330fbe3 mt76x0: remove unused variable in mt76x0_dev a56efc5 mt76x0: remove hw_atomic_mutex mutex in mt76x0_dev abd1daa mt76x2: move mt76x2_dev in mt76x02_util.h d5d1e59 mt76x0: merge mt76x0_dev in mt76x02_dev e236ba5 mt76: move mt76x02_mac_process_rx in mt76x02-lib module 724d547 mt76: unify rxwi parsing between mt76x2 and mt76x0 drivers ec3d829 mt76: move mt76x02_tx in mt76x02-lib module 159f767 mt76: move txrx shared routines in mt76x02_txrx.c 9c874cd mt76: rename mt76x02_util.h in mt76x02.h fd9174f mt76x2: remove leftover function declatarions 608708a mt76: move tpc routines in mt76x02-lib module 45b8f5e mt76: move mt76x02_tx_prepare_skb in mt76x02_txrx.c 9a39521 mt76: usb: move mt76x02u_tx_complete_skb in mt76x02_usb_core.c 3770c54 mt76: move mt76x02_mac_poll_tx_status in mt76x02-lib moudle 9730290 mt76: move mt76x02_tx_complete in mt76x02-lib module 99e0486 mt76: use mt76x02_dev instead of mt76_dev in mt76x02_mmio.c 3d2cfe3 mt76: move tx_tasklet management in mt76x02-lib moudle e61671e mt76: move irq handler in mt76x02-lib moudle d533f13 mt76x0: pci: report firmware version using ethtool Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/kernel/mt76')
-rw-r--r--package/kernel/mt76/Makefile18
1 files changed, 9 insertions, 9 deletions
diff --git a/package/kernel/mt76/Makefile b/package/kernel/mt76/Makefile
index 798f6f0c86..49d459623c 100644
--- a/package/kernel/mt76/Makefile
+++ b/package/kernel/mt76/Makefile
@@ -8,9 +8,9 @@ PKG_LICENSE_FILES:=
PKG_SOURCE_URL:=https://github.com/openwrt/mt76
PKG_SOURCE_PROTO:=git
-PKG_SOURCE_DATE:=2018-10-01
-PKG_SOURCE_VERSION:=94d44458f1f1863eddcc9e7dad817e48552753f6
-PKG_MIRROR_HASH:=c9db04557fff817cd4aedc9e4f946e3102cf169ec7871122055e758227fc6376
+PKG_SOURCE_DATE:=2018-10-05
+PKG_SOURCE_VERSION:=d533f1351834ba2899897b090aa56a5f5b922bd7
+PKG_MIRROR_HASH:=27e9c4cf876ad26a6f854d2b00d7e3b100980e820444f13986bf66f3f539eed3
PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
PKG_BUILD_PARALLEL:=1
@@ -63,7 +63,7 @@ endef
define KernelPackage/mt76x02-usb
$(KernelPackage/mt76-default)
TITLE:=MediaTek MT76x0/MT76x2 USB wireless driver common code
- DEPENDS+=+kmod-mt76-usb
+ DEPENDS+=+kmod-mt76-usb +kmod-mt76x02-common
HIDDEN:=1
FILES:=$(PKG_BUILD_DIR)/mt76x02-usb.ko
endef
@@ -98,7 +98,7 @@ define KernelPackage/mt76x2-common
TITLE:=MediaTek MT76x2 wireless driver common code
DEPENDS+=+kmod-mt76-core +kmod-mt76x02-common
HIDDEN:=1
- FILES:=$(PKG_BUILD_DIR)/mt76x2-common.ko
+ FILES:=$(PKG_BUILD_DIR)/mt76x2/mt76x2-common.ko
endef
define KernelPackage/mt76x2u
@@ -106,7 +106,7 @@ define KernelPackage/mt76x2u
TITLE:=MediaTek MT76x2U wireless driver
DEPENDS+=+kmod-mt76x2-common +kmod-mt76x02-usb
FILES:=\
- $(PKG_BUILD_DIR)/mt76x2u.ko
+ $(PKG_BUILD_DIR)/mt76x2/mt76x2u.ko
AUTOLOAD:=$(call AutoProbe,mt76x2u)
endef
@@ -115,7 +115,7 @@ define KernelPackage/mt76x2
TITLE:=MediaTek MT76x2 wireless driver
DEPENDS+=+kmod-mt76x2-common
FILES:=\
- $(PKG_BUILD_DIR)/mt76x2e.ko
+ $(PKG_BUILD_DIR)/mt76x2/mt76x2e.ko
AUTOLOAD:=$(call AutoProbe,mt76x2e)
endef
@@ -160,10 +160,10 @@ ifdef CONFIG_PACKAGE_kmod-mt76x2-common
PKG_MAKE_FLAGS += CONFIG_MT76x2_COMMON=m
endif
ifdef CONFIG_PACKAGE_kmod-mt76x2
- PKG_MAKE_FLAGS += CONFIG_MT76X2E=m
+ PKG_MAKE_FLAGS += CONFIG_MT76x2E=m
endif
ifdef CONFIG_PACKAGE_kmod-mt76x2u
- PKG_MAKE_FLAGS += CONFIG_MT76X2U=m
+ PKG_MAKE_FLAGS += CONFIG_MT76x2U=m
endif
ifdef CONFIG_PACKAGE_kmod-mt7603
PKG_MAKE_FLAGS += CONFIG_MT7603E=m