aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorPawel Dembicki <paweldembicki@gmail.com>2020-08-25 15:26:05 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-10-02 17:08:28 +0200
commit2d72671b6e7469dbc5b2e79cb1be77c4e13a9c92 (patch)
treeee11b259a6ec3f72f5faf7b4baffd3797dc1f1c5 /package/kernel
parent127db180b644f24c6914661a4ab318f320f5b719 (diff)
downloadupstream-2d72671b6e7469dbc5b2e79cb1be77c4e13a9c92.tar.gz
upstream-2d72671b6e7469dbc5b2e79cb1be77c4e13a9c92.tar.bz2
upstream-2d72671b6e7469dbc5b2e79cb1be77c4e13a9c92.zip
layerscape: add layerscape's SATA driver package
This patch intruduce SATA support for layerscape devices. Target specific package with ahci_qoriq driver was added to local modules.mk. Kmod package was added to default packages for devices with SATA interface. Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com> Reviewed-by: Yangbo Lu <yangbo.lu@nxp.com>
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/linux/modules/block.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/block.mk b/package/kernel/linux/modules/block.mk
index 8a7232d8be..373c9fbaab 100644
--- a/package/kernel/linux/modules/block.mk
+++ b/package/kernel/linux/modules/block.mk
@@ -65,7 +65,7 @@ define KernelPackage/ata-ahci-platform
$(LINUX_DIR)/drivers/ata/ahci_platform.ko \
$(LINUX_DIR)/drivers/ata/libahci_platform.ko
AUTOLOAD:=$(call AutoLoad,40,libahci libahci_platform ahci_platform,1)
- $(call AddDepends/ata,@TARGET_ipq806x||TARGET_sunxi)
+ $(call AddDepends/ata,@TARGET_ipq806x||TARGET_layerscape||TARGET_sunxi)
endef
define KernelPackage/ata-ahci-platform/description