aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorToke Høiland-Jørgensen <toke@toke.dk>2020-05-06 21:58:30 +0200
committerKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>2020-06-06 19:15:43 +0100
commit56db8e461546c06f9103b5965e697f2d582d4bdc (patch)
treefc3fea0eef9fa3816499e3b65bbf538c52fc4474 /package/kernel
parent4e65838871e27b476e910f4fdfb746dd61998e43 (diff)
downloadupstream-56db8e461546c06f9103b5965e697f2d582d4bdc.tar.gz
upstream-56db8e461546c06f9103b5965e697f2d582d4bdc.tar.bz2
upstream-56db8e461546c06f9103b5965e697f2d582d4bdc.zip
kernel: Add kmod-sch-cake-virtual intermediate package
As reported in https://github.com/openwrt/packages/issues/12072, the imagebuilder fails due to a dependency resolution error when the userspace packages are built using a target that has a different kernel version than that which is being run. To resolve this, add a virtual kernel package with the conditional dependency currently used in sqm-scripts. The idea is to move the sqm-scripts dependency to this virtual package, which hopefully should be consistent with the actual kernel module being built. Signed-off-by: Toke Høiland-Jørgensen <toke@toke.dk>
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/kmod-sched-cake-oot/Makefile18
1 files changed, 15 insertions, 3 deletions
diff --git a/package/kernel/kmod-sched-cake-oot/Makefile b/package/kernel/kmod-sched-cake-oot/Makefile
index 963681c1fb..65042ce1f2 100644
--- a/package/kernel/kmod-sched-cake-oot/Makefile
+++ b/package/kernel/kmod-sched-cake-oot/Makefile
@@ -29,14 +29,26 @@ define KernelPackage/sched-cake-oot
DEPENDS:=@LINUX_4_14 +kmod-sched-core +kmod-ipt-conntrack
endef
-include $(INCLUDE_DIR)/kernel-defaults.mk
-
-define KernelPackage/sched-cake/description
+define KernelPackage/sched-cake-oot/description
O(ut) O(f) T(ree) Common Applications Kept Enhanced fq_codel/blue derived shaper
endef
+define KernelPackage/sched-cake-virtual
+ SUBMENU:=Network Support
+ TITLE:=Virtual package for sched-cake
+ URL:=https://github.com/dtaht/sch_cake
+ DEPENDS:=+!LINUX_4_14:kmod-sched-cake +LINUX_4_14:kmod-sched-cake-oot
+endef
+
+define KernelPackage/sched-cake-virtual/description
+ Virtual package for resolving sch_cake dependencies
+endef
+
+include $(INCLUDE_DIR)/kernel-defaults.mk
+
define Build/Compile
$(KERNEL_MAKE) M="$(PKG_BUILD_DIR)" modules
endef
$(eval $(call KernelPackage,sched-cake-oot))
+$(eval $(call KernelPackage,sched-cake-virtual))