aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2011-03-10 14:30:05 +0000
committerJo-Philipp Wich <jow@openwrt.org>2011-03-10 14:30:05 +0000
commitcce100286938c005f087eaa85e0d230fff4916f8 (patch)
treef9df9b05a86429158f3746bf9974d4dfd52a5072 /package/kernel
parentcefba2ca2fc2eac0289b93faa38de5e03b5022ee (diff)
downloadupstream-cce100286938c005f087eaa85e0d230fff4916f8.tar.gz
upstream-cce100286938c005f087eaa85e0d230fff4916f8.tar.bz2
upstream-cce100286938c005f087eaa85e0d230fff4916f8.zip
kernel: fix usage of CompareKernelPatchVer for kmod-gre
SVN-Revision: 26010
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/netsupport.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/kernel/modules/netsupport.mk b/package/kernel/modules/netsupport.mk
index 8379931f1a..25e2ac42c2 100644
--- a/package/kernel/modules/netsupport.mk
+++ b/package/kernel/modules/netsupport.mk
@@ -371,11 +371,11 @@ define KernelPackage/gre
SUBMENU:=$(NETWORK_SUPPORT_MENU)
TITLE:=GRE support
KCONFIG:=CONFIG_NET_IPGRE \
- $(if $(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),le,2.6.37)),CONFIG_NET_IPGRE_DEMUX)
+ $(if $(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.37)),CONFIG_NET_IPGRE_DEMUX)
FILES=$(LINUX_DIR)/net/ipv4/ip_gre.ko \
- $(if $(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),le,2.6.37)),$(LINUX_DIR)/net/ipv4/gre.ko)
+ $(if $(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.37)),$(LINUX_DIR)/net/ipv4/gre.ko)
AUTOLOAD:=$(call AutoLoad,39, \
- $(if $(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),le,2.6.37)),gre) ip_gre)
+ $(if $(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.37)),gre) ip_gre)
endef
define KernelPackage/gre/description