aboutsummaryrefslogtreecommitdiffstats
path: root/package/keynote/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2007-03-28 00:06:18 +0000
committerNicolas Thill <nico@openwrt.org>2007-03-28 00:06:18 +0000
commitf725f0dc49b28b19ff81db646495e1db0e2031f4 (patch)
treec044cf2450803e168f7f8ea592149ce42fabf239 /package/keynote/Makefile
parent10a482c83570f498eced1dd45ccee111def27f7f (diff)
downloadupstream-f725f0dc49b28b19ff81db646495e1db0e2031f4.tar.gz
upstream-f725f0dc49b28b19ff81db646495e1db0e2031f4.tar.bz2
upstream-f725f0dc49b28b19ff81db646495e1db0e2031f4.zip
tweak isakmpd & keynote makefiles
SVN-Revision: 6733
Diffstat (limited to 'package/keynote/Makefile')
-rw-r--r--package/keynote/Makefile13
1 files changed, 3 insertions, 10 deletions
diff --git a/package/keynote/Makefile b/package/keynote/Makefile
index 47469b61c3..8bec6e7725 100644
--- a/package/keynote/Makefile
+++ b/package/keynote/Makefile
@@ -7,7 +7,6 @@
# $Id$
include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=keynote
PKG_VERSION:=2.3
@@ -36,15 +35,9 @@ CONFIGURE_ARGS += \
--enable-static \
--enable-shared
-define Build/Compile
- $(call Build/Compile/Default, \
- LIBS="$(EXTRA_LDFLAGS) -L. -lkeynote -lm -lcrypto" \
- )
-endef
-
define Build/InstallDev
- mkdir -p $(STAGING_DIR)/usr/include
- $(CP) $(PKG_BUILD_DIR)/{assertion,header,keynote,signature}.h $(STAGING_DIR)/usr/include/
+ mkdir -p $(STAGING_DIR)/usr/include/keynote
+ $(CP) $(PKG_BUILD_DIR)/{assertion,header,keynote,signature}.h $(STAGING_DIR)/usr/include/keynote/
mkdir -p $(STAGING_DIR)/usr/lib
$(CP) $(PKG_BUILD_DIR)/libkeynote.a $(STAGING_DIR)/usr/lib/
endef
@@ -56,7 +49,7 @@ endef
define Package/keynote/install
$(INSTALL_DIR) $(1)/usr/sbin
- $(CP) $(PKG_BUILD_DIR)/keynote $(1)/usr/sbin/
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/keynote $(1)/usr/sbin/
endef
$(eval $(call BuildPackage,keynote))