aboutsummaryrefslogtreecommitdiffstats
path: root/package/libpcap
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2007-02-25 23:34:57 +0000
committerFelix Fietkau <nbd@openwrt.org>2007-02-25 23:34:57 +0000
commitd6299cafc8a31a7461ba8f26f4ac08ce5a8d93c6 (patch)
tree1c89b5d49f389d2b7c55d38ca165c6c16f184aa2 /package/libpcap
parent7ae75032c1ad9b23f6b4e8e2c9bb45f6cf3991bf (diff)
downloadupstream-d6299cafc8a31a7461ba8f26f4ac08ce5a8d93c6.tar.gz
upstream-d6299cafc8a31a7461ba8f26f4ac08ce5a8d93c6.tar.bz2
upstream-d6299cafc8a31a7461ba8f26f4ac08ce5a8d93c6.zip
various configure related cleanups
SVN-Revision: 6372
Diffstat (limited to 'package/libpcap')
-rw-r--r--package/libpcap/Makefile41
1 files changed, 7 insertions, 34 deletions
diff --git a/package/libpcap/Makefile b/package/libpcap/Makefile
index c33c034e8f..20eb17e70a 100644
--- a/package/libpcap/Makefile
+++ b/package/libpcap/Makefile
@@ -32,40 +32,13 @@ define Package/libpcap
URL:=http://www.tcpdump.org/
endef
-define Build/Configure
- (cd $(PKG_BUILD_DIR); rm -f config.cache; \
- $(TARGET_CONFIGURE_OPTS) \
- CFLAGS="$(TARGET_CFLAGS)" \
- CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
- LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
- ./configure \
- --target=$(GNU_TARGET_NAME) \
- --host=$(GNU_TARGET_NAME) \
- --build=$(GNU_HOST_NAME) \
- --program-prefix="" \
- --program-suffix="" \
- --prefix=/usr \
- --exec-prefix=/usr \
- --bindir=/usr/bin \
- --datadir=/usr/share \
- --includedir=/usr/include \
- --infodir=/usr/share/info \
- --libdir=/usr/lib \
- --libexecdir=/usr/lib \
- --localstatedir=/var \
- --mandir=/usr/share/man \
- --sbindir=/usr/sbin \
- --sysconfdir=/etc \
- $(DISABLE_NLS) \
- $(DISABLE_LARGEFILE) \
- --enable-shared \
- --enable-static \
- --disable-yydebug \
- --enable-ipv6 \
- --with-build-cc="$(HOSTCC)" \
- --with-pcap=linux \
- );
-endef
+CONFIGURE_ARGS += \
+ --enable-shared \
+ --enable-static \
+ --disable-yydebug \
+ --enable-ipv6 \
+ --with-build-cc="$(HOSTCC)" \
+ --with-pcap=linux
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \