aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/libiconv-full
diff options
context:
space:
mode:
authorJake Staehle <jacob@staehle.us>2017-10-24 13:09:37 -0500
committerHauke Mehrtens <hauke@hauke-m.de>2017-12-19 22:23:42 +0100
commite80ab48777d83d8c24fcd397a85649f08b6b5f87 (patch)
tree7cd06ed6fa04b46e67525780b7516b8623c0c557 /package/libs/libiconv-full
parent95fe3c51e5e1219fc29ce1776f94c23642e84474 (diff)
downloadupstream-e80ab48777d83d8c24fcd397a85649f08b6b5f87.tar.gz
upstream-e80ab48777d83d8c24fcd397a85649f08b6b5f87.tar.bz2
upstream-e80ab48777d83d8c24fcd397a85649f08b6b5f87.zip
libiconv-full: fix compile-time linking error GCC7
LEDE Flyspray Task 1091: Fix libiconv-full 'undefined reference' compile linker error using GCC7 Musl Tested with targets x86 (i386 and x86_64) Addition of CFLAGS "std=gnu89" fixes the linker issues, credit to harrylwc Issue found with 'minidlna' package, which depends on 'libiconv-full' Error in compile log: ../lib/.libs/libiconv.so: undefined reference to `aliases_lookup' ../lib/.libs/libiconv.so: undefined reference to `aliases2_lookup' collect2: error: ld returned 1 exit status Makefile:64: recipe for target 'iconv_no_i18n' failed Signed-off-by: Jake Staehle <jacob@staehle.us>
Diffstat (limited to 'package/libs/libiconv-full')
-rw-r--r--package/libs/libiconv-full/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/libs/libiconv-full/Makefile b/package/libs/libiconv-full/Makefile
index 9776711a79..ac7bfddf56 100644
--- a/package/libs/libiconv-full/Makefile
+++ b/package/libs/libiconv-full/Makefile
@@ -51,7 +51,7 @@ define Package/iconv
TITLE+= utility
endef
-TARGET_CFLAGS += $(FPIC) -DUSE_DOS
+TARGET_CFLAGS += $(FPIC) -DUSE_DOS -std=gnu89
CONFIGURE_ARGS += \
--enable-shared \