aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/libpcap/Makefile
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2019-10-18 12:10:06 +0000
committerYousong Zhou <yszhou4tech@gmail.com>2019-10-21 01:37:43 +0000
commite8f79474c97949454b8d0ea966be006013471336 (patch)
tree455ecd9ef7ca2df6c719e20bfcaa5633a8419a70 /package/libs/libpcap/Makefile
parent758a4d1766b3668422881480db8c3c6f94ebc2ea (diff)
downloadupstream-e8f79474c97949454b8d0ea966be006013471336.tar.gz
upstream-e8f79474c97949454b8d0ea966be006013471336.tar.bz2
upstream-e8f79474c97949454b8d0ea966be006013471336.zip
libpcap: build with cmake
The main motivation is to drop and stop maintaining "100-debian_shared_lib.patch". It lacks the logic to include custom implementation of several functions like pcap_strlcpy() which can cause build failures when glibc is used [2] CAN and CAN-USB support related symbols are now handled by general linux support, see [1] "-ffunction-sections -fdata-sections" were removed as they should help much for shared libraries Size comparison before and after the change -rw-r--r-- 1 yunion yunion 238042 Oct 18 11:42 ipkg-x86_64/libpcap/usr/lib/libpcap.so.1 lrwxrwxrwx 1 yunion yunion 16 Oct 18 13:03 ipkg-x86_64/libpcap/usr/lib/libpcap.so.1 -> libpcap.so.1.9.1 -rwxr-xr-x 1 yunion yunion 229867 Oct 18 13:03 ipkg-x86_64/libpcap/usr/lib/libpcap.so.1.9.1 [1] On Linux, handle all CAN captures with pcap-linux.c, in cooked mode, https://github.com/the-tcpdump-group/libpcap/commit/93ca5ff7030aaf1219e1de05ec89a68384bfc50b [2] https://github.com/openwrt/packages/issues/10270 Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
Diffstat (limited to 'package/libs/libpcap/Makefile')
-rw-r--r--package/libs/libpcap/Makefile82
1 files changed, 29 insertions, 53 deletions
diff --git a/package/libs/libpcap/Makefile b/package/libs/libpcap/Makefile
index fae955a54d..69af9d0700 100644
--- a/package/libs/libpcap/Makefile
+++ b/package/libs/libpcap/Makefile
@@ -9,22 +9,23 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libpcap
PKG_VERSION:=1.9.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.us.tcpdump.org/release/ \
http://www.tcpdump.org/release/
PKG_HASH:=635237637c5b619bcceba91900666b64d56ecb7be63f298f601ec786ce087094
-PKG_FIXUP:=patch-libtool
PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
-PKG_INSTALL:=1
+CMAKE_INSTALL:=1
PKG_BUILD_PARALLEL:=1
+
PKG_LICENSE:=BSD-3-Clause
+PKG_LICENSE_FILES:=LICENSE
include $(INCLUDE_DIR)/package.mk
-include $(INCLUDE_DIR)/kernel.mk
+include $(INCLUDE_DIR)/cmake.mk
define Package/libpcap
SECTION:=libs
@@ -44,55 +45,30 @@ define Package/libpcap/config
source "$(SOURCE)/Config.in"
endef
-TARGET_CFLAGS += \
- -ffunction-sections \
- -fdata-sections
-
-CONFIGURE_VARS += \
- ac_cv_linux_vers=$(LINUX_VERSION) \
- ac_cv_header_libusb_1_0_libusb_h=no
-
-ifeq ($(CONFIG_PCAP_HAS_NETFILTER),)
-CONFIGURE_VARS += \
- ac_cv_netfilter_can_compile=no
-endif
-
-CONFIGURE_ARGS += \
- --enable-shared \
- --disable-yydebug \
- --with-pcap=linux \
- --without-septel \
- --without-dag \
- --without-libnl \
- --without-snf \
- --disable-can \
- --disable-canusb \
- --disable-dbus \
- --disable-bluetooth
-
-ifeq ($(CONFIG_IPV6),y)
-CONFIGURE_ARGS += \
- --enable-ipv6
-endif
-
-MAKE_FLAGS += \
- CCOPT="$(TARGET_CFLAGS) -I$(BUILD_DIR)/linux/include"
-
-define Build/Configure
- $(call Build/Configure/Default)
- $(if $(CONFIG_PCAP_HAS_USB),,$(SED) '/^#define PCAP_SUPPORT_USB/D' $(PKG_BUILD_DIR)/config.h)
- $(if $(CONFIG_PCAP_HAS_USB),,$(SED) 's/pcap-usb-linux.c *//' $(PKG_BUILD_DIR)/Makefile)
- $(if $(CONFIG_PCAP_HAS_BT),,$(SED) '/^#define PCAP_SUPPORT_BT/D' $(PKG_BUILD_DIR)/config.h)
- $(if $(CONFIG_PCAP_HAS_BT),,$(SED) 's/pcap-bt-linux.c *//' $(PKG_BUILD_DIR)/Makefile)
-endef
-
-define Build/InstallDev
- $(INSTALL_DIR) $(1)/usr/include
- $(CP) $(PKG_INSTALL_DIR)/usr/include/pcap* $(1)/usr/include/
-
- $(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/libpcap.{a,so*} $(1)/usr/lib/
-endef
+CMAKE_OPTIONS += \
+ -DBUILD_SHARED_LIBS=ON \
+ -DBUILD_WITH_LIBNL=OFF \
+
+# grep 'option(DISABLE_' CMakeLists.txt | cut -f2 -d'(' | cut -f1 -d' ' | sort --unique
+CMAKE_OPTIONS += \
+ -DDISABLE_DAG=ON \
+ -DDISABLE_DBUS=ON \
+ -DDISABLE_NETMAP=ON \
+ -DDISABLE_RDMA=ON \
+ -DDISABLE_SEPTEL=ON \
+ -DDISABLE_SNF=ON \
+ -DDISABLE_TC=ON \
+
+# Debugging options
+CMAKE_OPTIONS += \
+ -DBDEBUG=OFF \
+ -DYYDEBUG=OFF \
+
+CMAKE_OPTIONS += $(if $(CONFIG_PCAP_HAS_USB) ,,-DDISABLE_USB=ON)
+CMAKE_OPTIONS += $(if $(CONFIG_PCAP_HAS_BT) ,,-DDISABLE_BLUETOOTH=ON)
+CMAKE_OPTIONS += $(if $(CONFIG_PCAP_HAS_NETFILTER) ,,-DPCAP_SUPPORT_NETFILTER=OFF)
+
+CMAKE_OPTIONS += $(if $(CONFIG_IPV6),-DINET6=ON,-DINET6=OFF)
define Package/libpcap/install
$(INSTALL_DIR) $(1)/usr/lib