aboutsummaryrefslogtreecommitdiffstats
path: root/package/libs/openssl/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-03-06 07:57:10 +0000
committerJohn Crispin <john@openwrt.org>2015-03-06 07:57:10 +0000
commit8573891dfeb55e96d878382a242ee34a7d51df37 (patch)
tree154bb94d6676c613d2edd77d8a26660dabfa6dad /package/libs/openssl/Makefile
parent57c7bed820edc45d59575c82d1bfd30cacf38395 (diff)
downloadupstream-8573891dfeb55e96d878382a242ee34a7d51df37.tar.gz
upstream-8573891dfeb55e96d878382a242ee34a7d51df37.tar.bz2
upstream-8573891dfeb55e96d878382a242ee34a7d51df37.zip
openssl: enable ARM assembly acceleration
Tested myself on ixp4xx and mvebu, and (originally) by Daniel on i.MX6. Also tested on a MIPS target, to make sure the change to ASFLAGS does not break things. Based on a patch submitted by Daniel Drown: https://lists.openwrt.org/pipermail/openwrt-devel/2014-July/026639.html Signed-off-by: Claudio Leite <leitec@staticky.com> Signed-off-by: Daniel Drown <dan-openwrt@drown.org> SVN-Revision: 44618
Diffstat (limited to 'package/libs/openssl/Makefile')
-rw-r--r--package/libs/openssl/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/package/libs/openssl/Makefile b/package/libs/openssl/Makefile
index 42165a733c..40f4061a2a 100644
--- a/package/libs/openssl/Makefile
+++ b/package/libs/openssl/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=openssl
PKG_VERSION:=1.0.2
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_USE_MIPS16:=0
PKG_BUILD_PARALLEL:=1
@@ -118,6 +118,8 @@ else
OPENSSL_OPTIONS+=no-sse2
ifeq ($(CONFIG_mips)$(CONFIG_mipsel),y)
OPENSSL_TARGET:=linux-mips-openwrt
+ else ifeq ($(CONFIG_arm)$(CONFIG_armeb),y)
+ OPENSSL_TARGET:=linux-armv4-openwrt
else
OPENSSL_TARGET:=linux-generic-openwrt
OPENSSL_OPTIONS+=no-perlasm
@@ -156,7 +158,7 @@ TARGET_CFLAGS += $(FPIC)
define Build/Compile
+$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
CC="$(TARGET_CC)" \
- ASFLAGS="$(TARGET_ASFLAGS) -c" \
+ ASFLAGS="$(TARGET_ASFLAGS) -I$(PKG_BUILD_DIR)/crypto -c" \
AR="$(TARGET_CROSS)ar r" \
RANLIB="$(TARGET_CROSS)ranlib" \
OPENWRT_OPTIMIZATION_FLAGS="$(TARGET_CFLAGS)" \
@@ -164,7 +166,7 @@ define Build/Compile
all
+$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
CC="$(TARGET_CC)" \
- ASFLAGS="$(TARGET_ASFLAGS) -c" \
+ ASFLAGS="$(TARGET_ASFLAGS) -I$(PKG_BUILD_DIR)/crypto -c" \
AR="$(TARGET_CROSS)ar r" \
RANLIB="$(TARGET_CROSS)ranlib" \
OPENWRT_OPTIMIZATION_FLAGS="$(TARGET_CFLAGS)" \