aboutsummaryrefslogtreecommitdiffstats
path: root/package/ltq-kpi2udp/patches
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2012-10-11 10:05:13 +0000
committerJohn Crispin <john@openwrt.org>2012-10-11 10:05:13 +0000
commita95775e4b2a9831decbc7f37a2e47985ea2ac222 (patch)
tree2a188f047a7da8e3868f734b26756551c9f7ec8e /package/ltq-kpi2udp/patches
parent06218a992e0ffa234d8c180f9a24415b2fb5fe62 (diff)
downloadupstream-a95775e4b2a9831decbc7f37a2e47985ea2ac222.tar.gz
upstream-a95775e4b2a9831decbc7f37a2e47985ea2ac222.tar.bz2
upstream-a95775e4b2a9831decbc7f37a2e47985ea2ac222.zip
drop unmaintained packages
SVN-Revision: 33723
Diffstat (limited to 'package/ltq-kpi2udp/patches')
-rw-r--r--package/ltq-kpi2udp/patches/100-configure.patch11
-rw-r--r--package/ltq-kpi2udp/patches/110-ifx_udp_redirect.patch29
2 files changed, 0 insertions, 40 deletions
diff --git a/package/ltq-kpi2udp/patches/100-configure.patch b/package/ltq-kpi2udp/patches/100-configure.patch
deleted file mode 100644
index 8f6704e9e8..0000000000
--- a/package/ltq-kpi2udp/patches/100-configure.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/configure.in
-+++ b/configure.in
-@@ -113,7 +113,7 @@
- AC_ARG_ENABLE(kernelbuild,
- AS_HELP_STRING(--enable-kernelbuild=x,Set the target kernel build path),
- [
-- if test -r $enableval/include/linux/autoconf.h; then
-+ if test -r $enableval/include/generated/autoconf.h; then
- AC_SUBST([KERNEL_BUILD_PATH],[$enableval])
- else
- AC_MSG_ERROR([The kernel build directory is not valid or not configured!])
diff --git a/package/ltq-kpi2udp/patches/110-ifx_udp_redirect.patch b/package/ltq-kpi2udp/patches/110-ifx_udp_redirect.patch
deleted file mode 100644
index abb3d353a1..0000000000
--- a/package/ltq-kpi2udp/patches/110-ifx_udp_redirect.patch
+++ /dev/null
@@ -1,29 +0,0 @@
---- a/ifx_udp_redirect.c
-+++ b/ifx_udp_redirect.c
-@@ -256,7 +256,7 @@
- {
- if (redtab.channels[i].in_use == IFX_TRUE)
- {
-- if (redtab.channels[i].sk->sk_lock.owner != 0)
-+ if (redtab.channels[i].sk->sk_lock.owned != 0)
- return IFX_TRUE;
- }
- }
-@@ -545,7 +545,7 @@
- #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,0))
- if (sk->num != htons(sport))
- #else
-- if (((struct inet_sock *)sk)->num != htons(sport))
-+ if (((struct inet_sock *)sk)->inet_num != htons(sport))
- #endif
- {
- return CALL_MK_SESSION_ERR;
-@@ -628,7 +628,7 @@
- #if (LINUX_VERSION_CODE < KERNEL_VERSION(2,6,0))
- if((vsock != NULL)&&(vsk != NULL)&&(vsk->num > 0))
- #else
-- if((vsock != NULL)&&(vsk != NULL)&&(((struct inet_sock *)vsk)->num > 0))
-+ if((vsock != NULL)&&(vsk != NULL)&&(((struct inet_sock *)vsk)->inet_num > 0))
- #endif
- {
- /*printk("[KPI2UDP] releasing vsock...%p, ops %p\n", vsock, vsock->ops);*/