aboutsummaryrefslogtreecommitdiffstats
path: root/package/mac80211/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-01-04 17:41:23 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-01-04 17:41:23 +0000
commitba21190710c33527351342956fa3ebe42cb5c4c9 (patch)
treed024cb3aa53c10ec9fa00ee537c53ae56c20fd85 /package/mac80211/Makefile
parent3b4931ef4db58d8dfbad51bec9a1782291a4359c (diff)
downloadupstream-ba21190710c33527351342956fa3ebe42cb5c4c9.tar.gz
upstream-ba21190710c33527351342956fa3ebe42cb5c4c9.tar.bz2
upstream-ba21190710c33527351342956fa3ebe42cb5c4c9.zip
mac80211: add dependency of PACKAGE_MAC80211_DEBUGFS
I wanted to use some statistics from /sys/kernel/debug/ieee80211, so I enabled PACKAGE_MAC80211_DEBUGFS. But I could not use it, because CONFIG_KERNEL_DEBUG_FS was not set and it's a little bit hidden. After manually setting CONFIG_KERNEL_DEBUG_FS to y, everything was fine. This patch automatically selects CONFIG_KERNEL_DEBUG_FS if PACKAGE_MAC80211_DEBUGFS is set. Additionally, the help text says "Say N unless you know you need this.", but it's default y. This help text is copied verbatim from the kernel's Kconfig and not true for us. So remove this part of the help text Signed-off-by: Stefan Hellermann <stefan@the2masters.de> SVN-Revision: 35014
Diffstat (limited to 'package/mac80211/Makefile')
-rw-r--r--package/mac80211/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/package/mac80211/Makefile b/package/mac80211/Makefile
index f57d30353c..ac60193624 100644
--- a/package/mac80211/Makefile
+++ b/package/mac80211/Makefile
@@ -84,13 +84,12 @@ define KernelPackage/mac80211/config
config PACKAGE_MAC80211_DEBUGFS
bool "Export mac80211 internals in DebugFS"
+ select KERNEL_DEBUG_FS
default y
help
Select this to see extensive information about
the internal state of mac80211 in debugfs.
- Say N unless you know you need this.
-
config PACKAGE_MAC80211_MESH
bool "Enable 802.11s mesh support"
default y