aboutsummaryrefslogtreecommitdiffstats
path: root/package/mac80211/patches/000-fix_kconfig.patch
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2013-06-15 20:14:06 +0000
committerFelix Fietkau <nbd@openwrt.org>2013-06-15 20:14:06 +0000
commit5ca4d24cd1043e142515ac66c44a26a2371978d3 (patch)
treef7411ae4df9fed440179fab0be52e2f1640544ed /package/mac80211/patches/000-fix_kconfig.patch
parentd3a7b5633c7c1ea142cb8c0872cab484ca385c92 (diff)
downloadupstream-5ca4d24cd1043e142515ac66c44a26a2371978d3.tar.gz
upstream-5ca4d24cd1043e142515ac66c44a26a2371978d3.tar.bz2
upstream-5ca4d24cd1043e142515ac66c44a26a2371978d3.zip
mac80211: update to wireless-testing 2013-06-13 + latest backport infrastructure
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 36939
Diffstat (limited to 'package/mac80211/patches/000-fix_kconfig.patch')
-rw-r--r--package/mac80211/patches/000-fix_kconfig.patch16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/mac80211/patches/000-fix_kconfig.patch b/package/mac80211/patches/000-fix_kconfig.patch
new file mode 100644
index 0000000000..88d0b04984
--- /dev/null
+++ b/package/mac80211/patches/000-fix_kconfig.patch
@@ -0,0 +1,16 @@
+--- a/kconf/Makefile
++++ b/kconf/Makefile
+@@ -1,10 +1,10 @@
+-CFLAGS=-Wall -Wmissing-prototypes -Wstrict-prototypes -O2 -fomit-frame-pointer
++CFLAGS=-Wall -Wmissing-prototypes -Wstrict-prototypes -O2 -fomit-frame-pointer -DKBUILD_NO_NLS
+
+ LXDIALOG := lxdialog/checklist.o lxdialog/inputbox.o lxdialog/menubox.o lxdialog/textbox.o lxdialog/util.o lxdialog/yesno.o
+
+ conf: conf.o zconf.tab.o
+-mconf: LDFLAGS = -Wl,--no-as-needed $(shell ./lxdialog/check-lxdialog.sh -ldflags $(CC))
+-mconf: CFLAGS += -DCURSES_LOC="<ncurses.h>" -DLOCALE
++mconf: LDFLAGS = $(shell ./lxdialog/check-lxdialog.sh -ldflags $(CC))
++mconf: CFLAGS += -DCURSES_LOC="<ncurses.h>"
+ mconf: mconf.o zconf.tab.o $(LXDIALOG)
+
+ .PHONY: clean