aboutsummaryrefslogtreecommitdiffstats
path: root/package/mac80211
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2011-01-04 16:39:16 +0000
committerImre Kaloz <kaloz@openwrt.org>2011-01-04 16:39:16 +0000
commite9013bff6617e3881be4177d20f127613fdecf59 (patch)
tree213079ec942af798b969bac5282d8392923d6449 /package/mac80211
parentb99a637795efbb7aba2c5d4d77295c7012613759 (diff)
downloadupstream-e9013bff6617e3881be4177d20f127613fdecf59.tar.gz
upstream-e9013bff6617e3881be4177d20f127613fdecf59.tar.bz2
upstream-e9013bff6617e3881be4177d20f127613fdecf59.zip
fix md5sum, use our mirror with a fixed-up filename to make sure we get the right fw version
SVN-Revision: 24901
Diffstat (limited to 'package/mac80211')
-rw-r--r--package/mac80211/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/package/mac80211/Makefile b/package/mac80211/Makefile
index 5ce4a0116c..b1e12341e1 100644
--- a/package/mac80211/Makefile
+++ b/package/mac80211/Makefile
@@ -117,9 +117,9 @@ endef
$(eval $(call Download,p54spi))
define Download/carl9170
- FILE:=$(CARL9170_FW)
- URL:=http://www.kernel.org/pub/linux/kernel/people/chr/carl9170/fw/$(CARL9170_FW_VERSION)
- MD5SUM:=114c43846ed1d2f89cc92bd0e2ec0589
+ FILE:=$(CARL9170_FW)-$(CARL9170_FW_VERSION)
+ URL:=http://downloads.openwrt.org/sources/
+ MD5SUM:=9e33ac39dcd610aa1ad80bbf4f1abccf
endef
$(eval $(call Download,carl9170))
@@ -453,7 +453,7 @@ endef
define KernelPackage/carl9170/install
$(INSTALL_DIR) $(1)/lib/firmware
- $(INSTALL_DATA) $(DL_DIR)/$(CARL9170_FW) $(1)/lib/firmware/
+ $(INSTALL_DATA) $(DL_DIR)/$(CARL9170_FW)-$(CARL9170_FW_VERSION) $(1)/lib/firmware/$(CARL9170_FW)
endef