aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/ipv6/6to4
diff options
context:
space:
mode:
authorSteven Barth <cyrus@openwrt.org>2013-01-15 13:08:10 +0000
committerSteven Barth <cyrus@openwrt.org>2013-01-15 13:08:10 +0000
commit811cd2acf4ff784a746c421685ef189971beb141 (patch)
treea784793945e11eb313460d7e6d3ae649f659caa7 /package/network/ipv6/6to4
parent2a94f67029eb9c58faca930687751f0ca7202050 (diff)
downloadupstream-811cd2acf4ff784a746c421685ef189971beb141.tar.gz
upstream-811cd2acf4ff784a746c421685ef189971beb141.tar.bz2
upstream-811cd2acf4ff784a746c421685ef189971beb141.zip
6to4: add support for native IPv6 prefix handling
SVN-Revision: 35172
Diffstat (limited to 'package/network/ipv6/6to4')
-rw-r--r--package/network/ipv6/6to4/Makefile2
-rwxr-xr-xpackage/network/ipv6/6to4/files/6to4.sh1
2 files changed, 2 insertions, 1 deletions
diff --git a/package/network/ipv6/6to4/Makefile b/package/network/ipv6/6to4/Makefile
index f29571d86c..72906fba5b 100644
--- a/package/network/ipv6/6to4/Makefile
+++ b/package/network/ipv6/6to4/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=6to4
-PKG_VERSION:=11
+PKG_VERSION:=12
PKG_RELEASE:=1
include $(INCLUDE_DIR)/package.mk
diff --git a/package/network/ipv6/6to4/files/6to4.sh b/package/network/ipv6/6to4/files/6to4.sh
index 145f78a239..6f2fbd840c 100755
--- a/package/network/ipv6/6to4/files/6to4.sh
+++ b/package/network/ipv6/6to4/files/6to4.sh
@@ -63,6 +63,7 @@ proto_6to4_setup() {
proto_init_update "$link" 1
proto_add_ipv6_address "$local6" 16
+ proto_add_ipv6_prefix "$prefix6::/48"
proto_add_ipv6_route "::" 0 "::192.88.99.1"
proto_add_tunnel