aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services/hostapd
diff options
context:
space:
mode:
authorLeon M. George <leon@georgemail.eu>2021-01-12 09:38:02 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2021-01-14 03:54:06 +0100
commitfa02225ee656c18b084988246a0ad83fb202c374 (patch)
tree4b45a2af13bb251855a107f74637aea85ecab739 /package/network/services/hostapd
parentf72ce73e364d34f4235fcb02927523f9ce330175 (diff)
downloadupstream-fa02225ee656c18b084988246a0ad83fb202c374.tar.gz
upstream-fa02225ee656c18b084988246a0ad83fb202c374.tar.bz2
upstream-fa02225ee656c18b084988246a0ad83fb202c374.zip
hostapd: fix key_mgmt typo
The key_mgmt variable was mistyped when checking against "WPS", so the if clause was never entered. Fixes: f5753aae233f ("hostapd: add support for WPS pushbutton station") Signed-off-by: Leon M. George <leon@georgemail.eu> [add commit message, bump PKG_RELEASE] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'package/network/services/hostapd')
-rw-r--r--package/network/services/hostapd/Makefile2
-rw-r--r--package/network/services/hostapd/files/hostapd.sh2
2 files changed, 2 insertions, 2 deletions
diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index 53470a2c02..4f740951c0 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -7,7 +7,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=hostapd
-PKG_RELEASE:=26
+PKG_RELEASE:=27
PKG_SOURCE_URL:=http://w1.fi/hostap.git
PKG_SOURCE_PROTO:=git
diff --git a/package/network/services/hostapd/files/hostapd.sh b/package/network/services/hostapd/files/hostapd.sh
index d9a5332bee..815f22db74 100644
--- a/package/network/services/hostapd/files/hostapd.sh
+++ b/package/network/services/hostapd/files/hostapd.sh
@@ -1368,7 +1368,7 @@ wpa_supplicant_add_network() {
append network_data "mcast_rate=$mc_rate" "$N$T"
}
- if [ "$key_mgnt" = "WPS" ]; then
+ if [ "$key_mgmt" = "WPS" ]; then
echo "wps_cred_processing=1" >> "$_config"
else
cat >> "$_config" <<EOF