aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services/uhttpd
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-12-22 16:43:07 +0100
committerFelix Fietkau <nbd@nbd.name>2016-12-22 16:46:01 +0100
commit47cf2387798d04dab7f3386c4665a00428c61bf1 (patch)
tree17b7a4aa163896c29d0bb6ba8bd98f8b8f7499f8 /package/network/services/uhttpd
parentc7c1cf5618b6ca983c20510814b762eeab4937e5 (diff)
downloadupstream-47cf2387798d04dab7f3386c4665a00428c61bf1.tar.gz
upstream-47cf2387798d04dab7f3386c4665a00428c61bf1.tar.bz2
upstream-47cf2387798d04dab7f3386c4665a00428c61bf1.zip
uhttpd: drop uhttpd-mod-tls, it has been useless for years
Before the rewrite, uhttpd-mod-tls used to contain a tls plugin. Afterwards it was left in for compatibility reasons, but given how much has changed, and that we're about to change the default SSL implementation again, it's better to just drop this now Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/network/services/uhttpd')
-rw-r--r--package/network/services/uhttpd/Makefile39
1 files changed, 0 insertions, 39 deletions
diff --git a/package/network/services/uhttpd/Makefile b/package/network/services/uhttpd/Makefile
index 6f9fac95fe..39e8894ebc 100644
--- a/package/network/services/uhttpd/Makefile
+++ b/package/network/services/uhttpd/Makefile
@@ -49,40 +49,6 @@ define Package/uhttpd/config
endef
-define Package/uhttpd-mod-tls
- $(Package/uhttpd/default)
- TITLE+= (TLS plugin)
- DEPENDS:=uhttpd \
- +PACKAGE_uhttpd-mod-tls_polarssl:libustream-polarssl \
- +PACKAGE_uhttpd-mod-tls_mbedtls:libustream-mbedtls \
- +PACKAGE_uhttpd-mod-tls_cyassl:libustream-cyassl \
- +PACKAGE_uhttpd-mod-tls_openssl:libustream-openssl
-endef
-
-define Package/uhttpd-mod-tls/description
- The TLS plugin adds HTTPS support to uHTTPd.
-endef
-
-define Package/uhttpd-mod-tls/config
- choice
- depends on PACKAGE_uhttpd-mod-tls
- prompt "TLS Provider"
- default PACKAGE_uhttpd-mod-tls_polarssl
-
- config PACKAGE_uhttpd-mod-tls_mbedtls
- bool "mbedTLS"
-
- config PACKAGE_uhttpd-mod-tls_polarssl
- bool "PolarSSL"
-
- config PACKAGE_uhttpd-mod-tls_cyassl
- bool "CyaSSL"
-
- config PACKAGE_uhttpd-mod-tls_openssl
- bool "OpenSSL"
- endchoice
-endef
-
define Package/uhttpd-mod-lua
$(Package/uhttpd/default)
TITLE+= (Lua plugin)
@@ -129,10 +95,6 @@ define Package/uhttpd/install
$(INSTALL_BIN) $(PKG_BUILD_DIR)/uhttpd $(1)/usr/sbin/uhttpd
endef
-define Package/uhttpd-mod-tls/install
- true
-endef
-
define Package/uhttpd-mod-lua/install
$(INSTALL_DIR) $(1)/usr/lib
$(INSTALL_BIN) $(PKG_BUILD_DIR)/uhttpd_lua.so $(1)/usr/lib/
@@ -146,6 +108,5 @@ endef
$(eval $(call BuildPackage,uhttpd))
-$(eval $(call BuildPackage,uhttpd-mod-tls))
$(eval $(call BuildPackage,uhttpd-mod-lua))
$(eval $(call BuildPackage,uhttpd-mod-ubus))