aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/services
diff options
context:
space:
mode:
authorDobroslaw Kijowski <dobo90@gmail.com>2020-08-26 10:05:18 +0200
committerPetr Štetiar <ynezz@true.cz>2020-12-23 16:36:08 +0100
commit1a9b896d8bce5f31a965dd22b01503313436b9ed (patch)
treec8af5fb183a7f8b43cc583e5625c5d17af55cb5b /package/network/services
parent3d8d2c3a80813b3e648a49468a0dcb3c7f6a92fa (diff)
downloadupstream-1a9b896d8bce5f31a965dd22b01503313436b9ed.tar.gz
upstream-1a9b896d8bce5f31a965dd22b01503313436b9ed.tar.bz2
upstream-1a9b896d8bce5f31a965dd22b01503313436b9ed.zip
treewide: nuke DRIVER_11W_SUPPORT
As of hostapd upstream commit 7d2ed8ba "Remove CONFIG_IEEE80211W build parameter" https://w1.fi/cgit/hostap/commit?id=7d2ed8bae86a31dd2df45c24b3f7281d55315482 802.11w feature is always enabled in the build time. It doesn't make sense to opt-in 802.11w per driver as hostapd will always be compiled with this feature enabled. As suggested by Hauke Mehrtens, for now keep 11w enabled in build_features.h for compatibility reasons. This option will be dropped when LuCI is adjusted. Signed-off-by: Dobroslaw Kijowski <dobo90@gmail.com>
Diffstat (limited to 'package/network/services')
-rw-r--r--package/network/services/hostapd/Config.in4
-rw-r--r--package/network/services/hostapd/Makefile6
-rw-r--r--package/network/services/hostapd/src/src/utils/build_features.h2
3 files changed, 1 insertions, 11 deletions
diff --git a/package/network/services/hostapd/Config.in b/package/network/services/hostapd/Config.in
index 8aa878d207..5c00f3e24e 100644
--- a/package/network/services/hostapd/Config.in
+++ b/package/network/services/hostapd/Config.in
@@ -79,10 +79,6 @@ config DRIVER_11AX_SUPPORT
bool
default n
-config DRIVER_11W_SUPPORT
- bool
- default n
-
config WPA_ENABLE_WEP
bool "Enable support for unsecure and obsolete WEP"
help
diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index 45e2e3e337..deb1d565bb 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -7,7 +7,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=hostapd
-PKG_RELEASE:=19
+PKG_RELEASE:=20
PKG_SOURCE_URL:=http://w1.fi/hostap.git
PKG_SOURCE_PROTO:=git
@@ -94,10 +94,6 @@ DRIVER_MAKEOPTS= \
CONFIG_IEEE80211AX=$(HOSTAPD_IEEE80211AX) \
CONFIG_DRIVER_WEXT=$(CONFIG_DRIVER_WEXT_SUPPORT) \
-ifneq ($(LOCAL_VARIANT),mini)
- DRIVER_MAKEOPTS += CONFIG_IEEE80211W=$(CONFIG_DRIVER_11W_SUPPORT)
-endif
-
ifeq ($(SSL_VARIANT),openssl)
DRIVER_MAKEOPTS += CONFIG_TLS=openssl CONFIG_SAE=y
TARGET_LDFLAGS += -lcrypto -lssl
diff --git a/package/network/services/hostapd/src/src/utils/build_features.h b/package/network/services/hostapd/src/src/utils/build_features.h
index 7ca65fa391..c7fccad413 100644
--- a/package/network/services/hostapd/src/src/utils/build_features.h
+++ b/package/network/services/hostapd/src/src/utils/build_features.h
@@ -23,10 +23,8 @@ static inline int has_feature(const char *feat)
if (!strcmp(feat, "11r"))
return 1;
#endif
-#ifdef CONFIG_IEEE80211W
if (!strcmp(feat, "11w"))
return 1;
-#endif
#ifdef CONFIG_ACS
if (!strcmp(feat, "acs"))
return 1;