aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/comgt
diff options
context:
space:
mode:
authorLorenzo Santina <lorenzo.santina@edu.unito.it>2017-09-11 15:27:53 +0200
committerMathias Kresin <dev@kresin.me>2017-09-13 08:07:54 +0200
commitfd84ecda7d3bfebb4237110b8efe2ab2713ea8e1 (patch)
tree5d2ed86484e32e8cdc6100e5615be7007cb5cee0 /package/network/utils/comgt
parentfb128057da92bdb6b2c4cd9ad9dd87637a4089b3 (diff)
downloadupstream-fd84ecda7d3bfebb4237110b8efe2ab2713ea8e1.tar.gz
upstream-fd84ecda7d3bfebb4237110b8efe2ab2713ea8e1.tar.bz2
upstream-fd84ecda7d3bfebb4237110b8efe2ab2713ea8e1.zip
treewide: fix shellscript syntax errors/typos
Fix multiple syntax errors in shelscripts (of packages only) These errors were causing many conditions to not working properly Signed-off-by: Lorenzo Santina <lorenzo.santina@edu.unito.it> [increase PKG_RELEASE, drop command substitution from directip.sh] Signed-off-by: Mathias Kresin <dev@kresin.em>
Diffstat (limited to 'package/network/utils/comgt')
-rw-r--r--package/network/utils/comgt/Makefile2
-rw-r--r--package/network/utils/comgt/files/3g.sh2
-rw-r--r--package/network/utils/comgt/files/directip.sh3
3 files changed, 3 insertions, 4 deletions
diff --git a/package/network/utils/comgt/Makefile b/package/network/utils/comgt/Makefile
index ce99a2a688..3b7f4b9022 100644
--- a/package/network/utils/comgt/Makefile
+++ b/package/network/utils/comgt/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=comgt
PKG_VERSION:=0.32
-PKG_RELEASE:=29
+PKG_RELEASE:=30
PKG_SOURCE:=$(PKG_NAME).$(PKG_VERSION).tgz
PKG_SOURCE_URL:=@SF/comgt
diff --git a/package/network/utils/comgt/files/3g.sh b/package/network/utils/comgt/files/3g.sh
index d438cb7a6d..0d02d4c4b9 100644
--- a/package/network/utils/comgt/files/3g.sh
+++ b/package/network/utils/comgt/files/3g.sh
@@ -109,4 +109,4 @@ proto_3g_teardown() {
proto_kill_command "$interface"
}
-[ -z "NOT_INCLUDED" ] || add_protocol 3g
+[ -z "$NOT_INCLUDED" ] || add_protocol 3g
diff --git a/package/network/utils/comgt/files/directip.sh b/package/network/utils/comgt/files/directip.sh
index 381bfb0000..3452fa5db7 100644
--- a/package/network/utils/comgt/files/directip.sh
+++ b/package/network/utils/comgt/files/directip.sh
@@ -44,8 +44,7 @@ proto_directip_setup() {
return 1
}
- cardinfo=$(gcom -d "$device" -s /etc/gcom/getcardinfo.gcom)
- [ -n $(echo "$cardinfo" | grep -q "Sierra Wireless") ] || {
+ gcom -d "$device" -s /etc/gcom/getcardinfo.gcom | grep -q "Sierra Wireless" || {
proto_notify_error "$interface" BAD_DEVICE
proto_block_restart "$interface"
return 1