aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/iproute2/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2014-10-19 23:04:17 +0000
committerFelix Fietkau <nbd@openwrt.org>2014-10-19 23:04:17 +0000
commit5ef89f1ec5d3053c571fee1a8d6313cdb817ef1a (patch)
treee4fe1af72af32b927ab8c86f0b9b88faee0468a5 /package/network/utils/iproute2/Makefile
parent6c2a0175536fd5837e6e002e8ae0e1fdab28d7d2 (diff)
downloadupstream-5ef89f1ec5d3053c571fee1a8d6313cdb817ef1a.tar.gz
upstream-5ef89f1ec5d3053c571fee1a8d6313cdb817ef1a.tar.bz2
upstream-5ef89f1ec5d3053c571fee1a8d6313cdb817ef1a.zip
iproute2: fix musl build
Signed-off-by: Felix Fietkau <nbd@openwrt.org> SVN-Revision: 42981
Diffstat (limited to 'package/network/utils/iproute2/Makefile')
-rw-r--r--package/network/utils/iproute2/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/package/network/utils/iproute2/Makefile b/package/network/utils/iproute2/Makefile
index e2f4b0218a..0b9134e0c9 100644
--- a/package/network/utils/iproute2/Makefile
+++ b/package/network/utils/iproute2/Makefile
@@ -81,6 +81,9 @@ ifdef CONFIG_USE_EGLIBC
TARGET_CFLAGS += -DHAVE_SETNS
endif
endif
+ifdef CONFIG_USE_MUSL
+ TARGET_CFLAGS += -DHAVE_SETNS
+endif
TARGET_CFLAGS += -ffunction-sections -fdata-sections