aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/iproute2/Makefile
diff options
context:
space:
mode:
authorHans Dedecker <dedeckeh@gmail.com>2019-02-19 15:14:42 +0100
committerHans Dedecker <dedeckeh@gmail.com>2019-02-19 15:22:28 +0100
commitde14f4301e7c40050a23a254bd62ed2edb496e09 (patch)
tree99dbb7ec401f3afa26be487f47a497462db4deb4 /package/network/utils/iproute2/Makefile
parent566bfa417e0e210a47b5481fa2001de0b47a9914 (diff)
downloadupstream-de14f4301e7c40050a23a254bd62ed2edb496e09.tar.gz
upstream-de14f4301e7c40050a23a254bd62ed2edb496e09.tar.bz2
upstream-de14f4301e7c40050a23a254bd62ed2edb496e09.zip
Revert "iproute2: simplify linking libelf for eBFP/XDP object file support"
This reverts commit 26681fa6a6fcbec0024906eb8367e9a3160521fb as it breaks the installation of the iproute2 utilities ip-bridge, ss, nstat, devlink and rdma for the ip-full variant Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
Diffstat (limited to 'package/network/utils/iproute2/Makefile')
-rw-r--r--package/network/utils/iproute2/Makefile11
1 files changed, 1 insertions, 10 deletions
diff --git a/package/network/utils/iproute2/Makefile b/package/network/utils/iproute2/Makefile
index a9bcfd40a0..56a16d095c 100644
--- a/package/network/utils/iproute2/Makefile
+++ b/package/network/utils/iproute2/Makefile
@@ -49,7 +49,7 @@ $(call Package/iproute2/Default)
VARIANT:=full
PROVIDES:=ip
ALTERNATIVES:=300:/sbin/ip:/usr/libexec/ip-full
- DEPENDS:=+libnl-tiny +libelf +(PACKAGE_devlink||PACKAGE_rdma):libmnl
+ DEPENDS:=+libnl-tiny +(PACKAGE_devlink||PACKAGE_rdma):libmnl
endef
define Package/tc
@@ -100,14 +100,6 @@ ifeq ($(BUILD_VARIANT),tiny)
IP_CONFIG_TINY:=y
endif
-ifeq ($(BUILD_VARIANT),full)
- HAVE_ELF:=y
-endif
-
-ifeq ($(BUILD_VARIANT),tc)
- HAVE_ELF:=y
-endif
-
ifdef CONFIG_PACKAGE_devlink
HAVE_MNL:=y
endif
@@ -129,7 +121,6 @@ MAKE_FLAGS += \
KERNEL_INCLUDE="$(LINUX_DIR)/user_headers/include" \
SHARED_LIBS="" \
IP_CONFIG_TINY=$(IP_CONFIG_TINY) \
- HAVE_ELF=$(HAVE_ELF) \
HAVE_MNL=$(HAVE_MNL) \
IPT_LIB_DIR=/usr/lib/iptables \
XT_LIB_DIR=/usr/lib/iptables \