aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/iptables
diff options
context:
space:
mode:
authorRosy Song <rosysong@rosinson.com>2018-08-09 14:47:31 +0800
committerHans Dedecker <dedeckeh@gmail.com>2018-09-26 22:40:37 +0200
commit2dc1f54b1205094e7c6036cae6275d2c326bad3e (patch)
treefc5f5a20d61f2f6f930e6babccf805c9af4cc14e /package/network/utils/iptables
parente86cdf85a7d0bd189e3452ec9e754baa1cf8ab74 (diff)
downloadupstream-2dc1f54b1205094e7c6036cae6275d2c326bad3e.tar.gz
upstream-2dc1f54b1205094e7c6036cae6275d2c326bad3e.tar.bz2
upstream-2dc1f54b1205094e7c6036cae6275d2c326bad3e.zip
iptables: fix dependency for libip6tc on IPV6
Signed-off-by: Rosy Song <rosysong@rosinson.com>
Diffstat (limited to 'package/network/utils/iptables')
-rw-r--r--package/network/utils/iptables/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/network/utils/iptables/Makefile b/package/network/utils/iptables/Makefile
index 4c5a581268..2beaa7135e 100644
--- a/package/network/utils/iptables/Makefile
+++ b/package/network/utils/iptables/Makefile
@@ -492,7 +492,7 @@ define Package/libiptc
$(call Package/iptables/Default)
SECTION:=libs
CATEGORY:=Libraries
- DEPENDS:=+libip4tc +libip6tc +libxtables
+ DEPENDS:=+libip4tc +IPV6:libip6tc +libxtables
ABI_VERSION:=$(PKG_VERSION)
TITLE:=IPv4/IPv6 firewall - shared libiptc library (compatibility stub)
endef
@@ -512,7 +512,7 @@ $(call Package/iptables/Default)
CATEGORY:=Libraries
TITLE:=IPv6 firewall - shared libiptc library
ABI_VERSION:=$(PKG_VERSION)
- DEPENDS:=+libxtables
+ DEPENDS:=@IPV6 +libxtables
endef
define Package/libxtables