aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/iptables
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2021-02-16 00:03:28 +0100
committerFelix Fietkau <nbd@nbd.name>2021-02-16 11:29:38 +0100
commitd02088762a701642b5eace2e6e80b17c6719dd78 (patch)
tree96bef329c649c75b888676913a1d8a2d221eb39f /package/network/utils/iptables
parenta5c4c404764e9125d7a6c435c2f8d840c68ceed2 (diff)
downloadupstream-d02088762a701642b5eace2e6e80b17c6719dd78.tar.gz
upstream-d02088762a701642b5eace2e6e80b17c6719dd78.tar.bz2
upstream-d02088762a701642b5eace2e6e80b17c6719dd78.zip
build: reorder more BuildPackages lines to deal with ABI_VERSION
After the ABI version rework, packages need to be declared in the order of their dependencies, so that dependent packages will use the right ABI version Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/network/utils/iptables')
-rw-r--r--package/network/utils/iptables/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/package/network/utils/iptables/Makefile b/package/network/utils/iptables/Makefile
index 9f033de72f..b1ac0be4e8 100644
--- a/package/network/utils/iptables/Makefile
+++ b/package/network/utils/iptables/Makefile
@@ -657,6 +657,10 @@ define BuildPlugin
$$(eval $$(call BuildPackage,$(1)))
endef
+$(eval $(call BuildPackage,libxtables))
+$(eval $(call BuildPackage,libxtables-nft))
+$(eval $(call BuildPackage,libip4tc))
+$(eval $(call BuildPackage,libip6tc))
$(eval $(call BuildPackage,iptables))
$(eval $(call BuildPackage,iptables-nft))
$(eval $(call BuildPlugin,iptables-mod-conntrack-extra,$(IPT_CONNTRACK_EXTRA-m)))
@@ -685,7 +689,4 @@ $(eval $(call BuildPackage,ip6tables))
$(eval $(call BuildPackage,ip6tables-nft))
$(eval $(call BuildPlugin,ip6tables-extra,$(IPT_IPV6_EXTRA-m)))
$(eval $(call BuildPlugin,ip6tables-mod-nat,$(IPT_NAT6-m)))
-$(eval $(call BuildPackage,libip4tc))
-$(eval $(call BuildPackage,libip6tc))
-$(eval $(call BuildPackage,libxtables))
-$(eval $(call BuildPackage,libxtables-nft))
+