aboutsummaryrefslogtreecommitdiffstats
path: root/package/network
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2013-06-06 14:02:24 +0000
committerJo-Philipp Wich <jow@openwrt.org>2013-06-06 14:02:24 +0000
commite94cf1c72bde8b724fd03b1fe1d7d474fa0605cd (patch)
tree790377ccb32fae657a42db72fc107040116a3343 /package/network
parent3f6736001282b5d0f79d34a4c34e2790f3233c20 (diff)
downloadupstream-e94cf1c72bde8b724fd03b1fe1d7d474fa0605cd.tar.gz
upstream-e94cf1c72bde8b724fd03b1fe1d7d474fa0605cd.tar.bz2
upstream-e94cf1c72bde8b724fd03b1fe1d7d474fa0605cd.zip
iptables: install libext*.a into staging dir
SVN-Revision: 36867
Diffstat (limited to 'package/network')
-rw-r--r--package/network/utils/iptables/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/network/utils/iptables/Makefile b/package/network/utils/iptables/Makefile
index 55f3a387bd..03f692ec68 100644
--- a/package/network/utils/iptables/Makefile
+++ b/package/network/utils/iptables/Makefile
@@ -375,6 +375,10 @@ define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/xtables.pc $(1)/usr/lib/pkgconfig/
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libip*tc.pc $(1)/usr/lib/pkgconfig/
+
+ # XXX: needed by firewall3
+ $(INSTALL_DIR) $(1)/usr/lib/iptables
+ $(CP) $(PKG_BUILD_DIR)/extensions/libext*.a $(1)/usr/lib/iptables/
endef
define Package/iptables/install