aboutsummaryrefslogtreecommitdiffstats
path: root/package/nw802-2.4/Makefile
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2007-09-21 13:06:31 +0000
committerNicolas Thill <nico@openwrt.org>2007-09-21 13:06:31 +0000
commit90eeef583391e5581fdf4c6f868923f6c8465a5b (patch)
tree2dd204128cf37038dbe8bbbff18366a0426e6a90 /package/nw802-2.4/Makefile
parentcd56b5255ccb5ab66118ca9cc6acab01921cd9fb (diff)
downloadupstream-90eeef583391e5581fdf4c6f868923f6c8465a5b.tar.gz
upstream-90eeef583391e5581fdf4c6f868923f6c8465a5b.tar.bz2
upstream-90eeef583391e5581fdf4c6f868923f6c8465a5b.zip
add support for NW8xx based USB video devices (closes: #2319)
SVN-Revision: 8914
Diffstat (limited to 'package/nw802-2.4/Makefile')
-rw-r--r--package/nw802-2.4/Makefile46
1 files changed, 46 insertions, 0 deletions
diff --git a/package/nw802-2.4/Makefile b/package/nw802-2.4/Makefile
new file mode 100644
index 0000000000..f9c2ad4ef9
--- /dev/null
+++ b/package/nw802-2.4/Makefile
@@ -0,0 +1,46 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
+
+PKG_NAME:=nw802-2.4
+PKG_VERSION:=0.0.99
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=@SF/nw802
+PKG_MD5SUM:=bf3512efaa48cfa972b16318011c1963
+
+include $(INCLUDE_DIR)/package.mk
+
+# XXX: remove @!TARGET_* later when we have USB support properly detected on all targets
+define KernelPackage/video-nw8xx
+ SUBMENU:=Video Support
+ TITLE:=NW8xx based USB webcam support
+ URL:=http://nw802.sourceforge.net/
+ DEPENDS:=@LINUX_2_6 @USB_SUPPORT +kmod-usb-video kmod-video-core @!TARGET_atheros @!TARGET_uml
+ FILES:=$(PKG_BUILD_DIR)/nw8xx.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,70,nw8xx)
+endef
+
+define KernelPackage/video-nw8xx/description
+ Kernel support for NW8xx based USB cameras.
+endef
+
+define Build/Compile
+ ln -sf $(LINUX_DIR)/drivers/media/video/usbvideo/usbvideo.h \
+ $(PKG_BUILD_DIR)/
+ $(MAKE) -C $(LINUX_DIR) \
+ ARCH="$(LINUX_KARCH)" \
+ CROSS_COMPILE="$(TARGET_CROSS)" \
+ SUBDIRS="$(PKG_BUILD_DIR)" \
+ modules
+endef
+
+$(eval $(call KernelPackage,video-nw8xx))