aboutsummaryrefslogtreecommitdiffstats
path: root/package/qos-scripts
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2006-12-19 02:53:02 +0000
committerFelix Fietkau <nbd@openwrt.org>2006-12-19 02:53:02 +0000
commite3a0c3b9fd0544c8f2ffed6210651c7821b46478 (patch)
tree53cf33cafbc675667c5cabeeaca94268a5919c7f /package/qos-scripts
parent64335e3ddbdf9276cf489ff914e3890e0c955fe4 (diff)
downloadupstream-e3a0c3b9fd0544c8f2ffed6210651c7821b46478.tar.gz
upstream-e3a0c3b9fd0544c8f2ffed6210651c7821b46478.tar.bz2
upstream-e3a0c3b9fd0544c8f2ffed6210651c7821b46478.zip
fix qos-scripts RED qdisc calculation for slow lines
SVN-Revision: 5853
Diffstat (limited to 'package/qos-scripts')
-rw-r--r--package/qos-scripts/Makefile2
-rwxr-xr-xpackage/qos-scripts/files/usr/lib/qos.sh1
2 files changed, 2 insertions, 1 deletions
diff --git a/package/qos-scripts/Makefile b/package/qos-scripts/Makefile
index 86eb6b3a23..bb5a9639f1 100644
--- a/package/qos-scripts/Makefile
+++ b/package/qos-scripts/Makefile
@@ -9,7 +9,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=qos-scripts
-PKG_VERSION:=0.9.3
+PKG_VERSION:=0.9.4
PKG_RELEASE:=1
PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
diff --git a/package/qos-scripts/files/usr/lib/qos.sh b/package/qos-scripts/files/usr/lib/qos.sh
index 8fcf9dc27f..724784ebd0 100755
--- a/package/qos-scripts/files/usr/lib/qos.sh
+++ b/package/qos-scripts/files/usr/lib/qos.sh
@@ -275,6 +275,7 @@ BEGIN {
print "sfq perturb 10 limit " cqlen
} else {
avpkt = 1200
+ if (min < avpkt) min = avpkt
min = int(limit * 1024 / 8 * 0.1)
dqb = cqlen * 1500
max = int(min + (dqb - min) * 0.25)