aboutsummaryrefslogtreecommitdiffstats
path: root/package/rt2500/Makefile
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2006-12-30 02:42:12 +0000
committerFlorian Fainelli <florian@openwrt.org>2006-12-30 02:42:12 +0000
commit134aed0662edc6e165d5460b9efd7666b3bc2a99 (patch)
tree6c756d6281461338e576b3388eecb51899ea1c27 /package/rt2500/Makefile
parent8d42c41adaaa48483a4b16941563fe15516fc716 (diff)
downloadupstream-134aed0662edc6e165d5460b9efd7666b3bc2a99.tar.gz
upstream-134aed0662edc6e165d5460b9efd7666b3bc2a99.tar.bz2
upstream-134aed0662edc6e165d5460b9efd7666b3bc2a99.zip
Add rt2500 as a kernel package, with pci id fix to make the latest a/b/g card be recognized
SVN-Revision: 5932
Diffstat (limited to 'package/rt2500/Makefile')
-rw-r--r--package/rt2500/Makefile48
1 files changed, 48 insertions, 0 deletions
diff --git a/package/rt2500/Makefile b/package/rt2500/Makefile
new file mode 100644
index 0000000000..ca1b837be4
--- /dev/null
+++ b/package/rt2500/Makefile
@@ -0,0 +1,48 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id: Makefile 5314 2006-10-27 19:14:43Z nico $
+
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
+
+PKG_NAME:=rt2500
+PKG_VERSION:=1.1.0-b4
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/rt2400
+PKG_MD5SUM:=83b8b9a091705c08d99268479f3b3b6a
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/package.mk
+
+define KernelPackage/rt2500
+ SUBMENU:=Wireless Drivers
+ TITLE:=Driver for ralink pci wireless chipsets
+ DEPENDS:=@USB_SUPPORT +wireless-tools
+ DESCRIPTION:=\
+ This package contains a driver for ralink rt2500 pci chipsets.
+ URL:=http://rt2x00.serialmonkey.com/
+ VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)
+ FILES:= \
+ $(PKG_BUILD_DIR)/Module/rt2500.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,50,rt2500)
+endef
+
+define Build/Compile
+ $(MAKE) -C "$(PKG_BUILD_DIR)/Module" \
+ CC="$(TARGET_CC)" \
+ LD="$(TARGET_CROSS)ld" \
+ ARCH="$(LINUX_KARCH)" \
+ PWD="$(PKG_BUILD_DIR)/Module" \
+ KERNDIR="$(LINUX_DIR)" \
+ PATCHLEVEL="$(patsubst 2.%,%,$(KERNEL))"
+endef
+
+$(eval $(call KernelPackage,rt2500))