aboutsummaryrefslogtreecommitdiffstats
path: root/package/system/ubox/Makefile
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2013-11-16 20:20:30 +0000
committerJohn Crispin <john@openwrt.org>2013-11-16 20:20:30 +0000
commit5fbfffe7f4ff7014fe5c942ec0c179a745f340c0 (patch)
treea3461e928ac38b5b6b07934287da9dff7885421a /package/system/ubox/Makefile
parentc4d8ddf1dc25f5ea55dda0a0f14209e1a4c6c78f (diff)
downloadupstream-5fbfffe7f4ff7014fe5c942ec0c179a745f340c0.tar.gz
upstream-5fbfffe7f4ff7014fe5c942ec0c179a745f340c0.tar.bz2
upstream-5fbfffe7f4ff7014fe5c942ec0c179a745f340c0.zip
procd: ubox: update to latest git head
move log service from procd to ubox some debloating on procd the preinit part of procd is now also a seperate binary Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 38822
Diffstat (limited to 'package/system/ubox/Makefile')
-rw-r--r--package/system/ubox/Makefile12
1 files changed, 7 insertions, 5 deletions
diff --git a/package/system/ubox/Makefile b/package/system/ubox/Makefile
index c913231505..15d222cb4e 100644
--- a/package/system/ubox/Makefile
+++ b/package/system/ubox/Makefile
@@ -1,13 +1,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=ubox
-PKG_VERSION:=2013-11-07.1
-PKG_RELEASE=$(PKG_SOURCE_VERSION)-1
+PKG_VERSION:=2013-11-16
+PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=git://nbd.name/luci2/ubox.git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=0588218d4bc58b0e099272338decbe4734f5678b
+PKG_SOURCE_VERSION:=b5dc53828bc69611cb474c95c9b23e70a2288391
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
CMAKE_INSTALL:=1
@@ -36,9 +36,11 @@ define Package/block-mount
endef
define Package/ubox/install
- $(INSTALL_DIR) $(1)/sbin $(1)/usr/sbin
+ $(INSTALL_DIR) $(1)/sbin $(1)/usr/sbin $(1)/lib/ $(1)/etc/init.d/
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/{mount_root,kmodloader} $(1)/sbin/
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/{mount_root,kmodloader,logd,logread,validate_data} $(1)/sbin/
+ $(INSTALL_BIN) ./files/log.init $(1)/etc/init.d/log
+ $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/libvalidate.so $(1)/lib
ln -s /sbin/mount_root $(1)/sbin/switch2jffs
ln -s /sbin/mount_root $(1)/sbin/jffs2reset
ln -s /sbin/mount_root $(1)/sbin/jffs2mark