aboutsummaryrefslogtreecommitdiffstats
path: root/package/uboot-envtools/patches
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2009-10-07 15:14:28 +0000
committerFlorian Fainelli <florian@openwrt.org>2009-10-07 15:14:28 +0000
commit7a7a5627cd47245ad50d2868bb4df72f28405001 (patch)
treec00db65e2411a9d782dd554b09b3eecf50624c4e /package/uboot-envtools/patches
parent96d804c54f2968987455be55efaed0940fb87d36 (diff)
downloadupstream-7a7a5627cd47245ad50d2868bb4df72f28405001.tar.gz
upstream-7a7a5627cd47245ad50d2868bb4df72f28405001.tar.bz2
upstream-7a7a5627cd47245ad50d2868bb4df72f28405001.zip
add uboot-envtools
SVN-Revision: 17981
Diffstat (limited to 'package/uboot-envtools/patches')
-rw-r--r--package/uboot-envtools/patches/001-crc32_func_signature.patch13
-rw-r--r--package/uboot-envtools/patches/002-makefile.patch33
2 files changed, 46 insertions, 0 deletions
diff --git a/package/uboot-envtools/patches/001-crc32_func_signature.patch b/package/uboot-envtools/patches/001-crc32_func_signature.patch
new file mode 100644
index 0000000000..9f9a2b223e
--- /dev/null
+++ b/package/uboot-envtools/patches/001-crc32_func_signature.patch
@@ -0,0 +1,13 @@
+Index: uboot-envtools-20080520/crc32.c
+===================================================================
+--- uboot-envtools-20080520.orig/crc32.c 2008-08-03 16:02:43.000000000 +0200
++++ uboot-envtools-20080520/crc32.c 2008-08-03 16:03:25.000000000 +0200
+@@ -154,7 +154,7 @@
+ #define DO8(buf) DO4(buf); DO4(buf);
+
+ /* ========================================================================= */
+-uint32_t ZEXPORT crc32 (uint32_t crc, const Bytef *buf, uInt len)
++uLong ZEXPORT crc32 (uLong crc, const Bytef *buf, uInt len)
+ {
+ #ifdef DYNAMIC_CRC_TABLE
+ if (crc_table_empty)
diff --git a/package/uboot-envtools/patches/002-makefile.patch b/package/uboot-envtools/patches/002-makefile.patch
new file mode 100644
index 0000000000..6086611e16
--- /dev/null
+++ b/package/uboot-envtools/patches/002-makefile.patch
@@ -0,0 +1,33 @@
+Index: uboot-envtools-20080520/Makefile
+===================================================================
+--- uboot-envtools-20080520.orig/Makefile 2008-08-03 15:50:27.000000000 +0200
++++ uboot-envtools-20080520/Makefile 2008-08-03 15:51:59.000000000 +0200
+@@ -21,12 +21,10 @@
+ # MA 02111-1307 USA
+ #
+
+-include $(TOPDIR)/config.mk
+-
+ SRCS := $(obj)crc32.c fw_env.c fw_env_main.c
+ HEADERS := fw_env.h
+
+-CPPFLAGS := -Wall -DUSE_HOSTCC -I$(SRCTREE)/include
++CPPFLAGS := -Wall -DUSE_HOSTCC -I/usr/include
+
+ ifeq ($(MTD_VERSION),old)
+ CPPFLAGS += -DMTD_OLD
+@@ -39,14 +37,3 @@
+
+ clean:
+ rm -f $(obj)fw_printenv $(obj)crc32.c
+-
+-$(obj)crc32.c:
+- ln -s $(src)../../lib_generic/crc32.c $(obj)crc32.c
+-
+-#########################################################################
+-
+-include $(TOPDIR)/rules.mk
+-
+-sinclude $(obj).depend
+-
+-#########################################################################