aboutsummaryrefslogtreecommitdiffstats
path: root/package/uboot-ifxmips/files/board
diff options
context:
space:
mode:
authorThomas Langer <thomas.langer@lantiq.com>2008-11-19 17:40:05 +0000
committerThomas Langer <thomas.langer@lantiq.com>2008-11-19 17:40:05 +0000
commit8294879df7f852871fd030d674943453b3096bc2 (patch)
tree6318ca0953b9ec71c18ecb46f81c874dfe799b1a /package/uboot-ifxmips/files/board
parente1e65079b407832393ffb37934d74df83223d05a (diff)
downloadupstream-8294879df7f852871fd030d674943453b3096bc2.tar.gz
upstream-8294879df7f852871fd030d674943453b3096bc2.tar.bz2
upstream-8294879df7f852871fd030d674943453b3096bc2.zip
cleanup uboot package
SVN-Revision: 13291
Diffstat (limited to 'package/uboot-ifxmips/files/board')
-rw-r--r--package/uboot-ifxmips/files/board/ifx/danube/Makefile (renamed from package/uboot-ifxmips/files/board/danube/Makefile)17
-rw-r--r--package/uboot-ifxmips/files/board/ifx/danube/README (renamed from package/uboot-ifxmips/files/board/danube/README)0
-rw-r--r--package/uboot-ifxmips/files/board/ifx/danube/config.mk (renamed from package/uboot-ifxmips/files/board/danube/config.mk)0
-rw-r--r--package/uboot-ifxmips/files/board/ifx/danube/danube.c (renamed from package/uboot-ifxmips/files/board/danube/danube.c)0
-rw-r--r--package/uboot-ifxmips/files/board/ifx/danube/ddr_settings.h (renamed from package/uboot-ifxmips/files/board/danube/ddr_settings.h)0
-rw-r--r--package/uboot-ifxmips/files/board/ifx/danube/ddr_settings_111.h (renamed from package/uboot-ifxmips/files/board/danube/ddr_settings_111.h)0
-rw-r--r--package/uboot-ifxmips/files/board/ifx/danube/ddr_settings_166.h (renamed from package/uboot-ifxmips/files/board/danube/ddr_settings_166.h)0
-rw-r--r--package/uboot-ifxmips/files/board/ifx/danube/ddr_settings_PROMOSDDR400.h (renamed from package/uboot-ifxmips/files/board/danube/ddr_settings_PROMOSDDR400.h)0
-rw-r--r--package/uboot-ifxmips/files/board/ifx/danube/ddr_settings_Samsung_166.h (renamed from package/uboot-ifxmips/files/board/danube/ddr_settings_Samsung_166.h)0
-rw-r--r--package/uboot-ifxmips/files/board/ifx/danube/ddr_settings_e111.h (renamed from package/uboot-ifxmips/files/board/danube/ddr_settings_e111.h)0
-rw-r--r--package/uboot-ifxmips/files/board/ifx/danube/ddr_settings_e166.h (renamed from package/uboot-ifxmips/files/board/danube/ddr_settings_e166.h)0
-rw-r--r--package/uboot-ifxmips/files/board/ifx/danube/ddr_settings_psc_166.h (renamed from package/uboot-ifxmips/files/board/danube/ddr_settings_psc_166.h)0
-rw-r--r--package/uboot-ifxmips/files/board/ifx/danube/ddr_settings_r111.h (renamed from package/uboot-ifxmips/files/board/danube/ddr_settings_r111.h)0
-rw-r--r--package/uboot-ifxmips/files/board/ifx/danube/ddr_settings_r166.h (renamed from package/uboot-ifxmips/files/board/danube/ddr_settings_r166.h)0
-rw-r--r--package/uboot-ifxmips/files/board/ifx/danube/flash.c (renamed from package/uboot-ifxmips/files/board/danube/flash.c)0
-rw-r--r--package/uboot-ifxmips/files/board/ifx/danube/lowlevel_init.S (renamed from package/uboot-ifxmips/files/board/danube/lowlevel_init.S)0
-rw-r--r--package/uboot-ifxmips/files/board/ifx/danube/pmuenable.S (renamed from package/uboot-ifxmips/files/board/danube/pmuenable.S)0
-rw-r--r--package/uboot-ifxmips/files/board/ifx/danube/u-boot-bootstrap.lds (renamed from package/uboot-ifxmips/files/board/danube/u-boot-bootstrap.lds)4
-rw-r--r--package/uboot-ifxmips/files/board/ifx/danube/u-boot.lds (renamed from package/uboot-ifxmips/files/board/danube/u-boot.lds)4
19 files changed, 14 insertions, 11 deletions
diff --git a/package/uboot-ifxmips/files/board/danube/Makefile b/package/uboot-ifxmips/files/board/ifx/danube/Makefile
index 0163fd96f8..565511773c 100644
--- a/package/uboot-ifxmips/files/board/danube/Makefile
+++ b/package/uboot-ifxmips/files/board/ifx/danube/Makefile
@@ -23,19 +23,22 @@
include $(TOPDIR)/config.mk
-LIB = lib$(BOARD).a
+LIB = $(obj)lib$(BOARD).a
-OBJS = $(BOARD).o flash.o
+COBJS = $(BOARD).o flash.o
SOBJS = lowlevel_init.o pmuenable.o
-$(LIB): .depend $(OBJS) $(SOBJS)
- $(AR) crv $@ $^
+SRCS := $(SOBJS:.o=.S) $(COBJS:.o=.c)
+OBJS := $(addprefix $(obj),$(COBJS))
+SOBJS := $(addprefix $(obj),$(SOBJS))
+
+$(LIB): $(obj).depend $(OBJS) $(SOBJS)
+ $(AR) $(ARFLAGS) $@ $(OBJS) $(SOBJS)
#########################################################################
-.depend: Makefile $(SOBJS:.o=.S) $(OBJS:.o=.c)
- $(CC) -M $(CFLAGS) $(SOBJS:.o=.S) $(OBJS:.o=.c) > $@
+include $(SRCTREE)/rules.mk
-sinclude .depend
+sinclude $(obj).depend
#########################################################################
diff --git a/package/uboot-ifxmips/files/board/danube/README b/package/uboot-ifxmips/files/board/ifx/danube/README
index d1c5c1e88c..d1c5c1e88c 100644
--- a/package/uboot-ifxmips/files/board/danube/README
+++ b/package/uboot-ifxmips/files/board/ifx/danube/README
diff --git a/package/uboot-ifxmips/files/board/danube/config.mk b/package/uboot-ifxmips/files/board/ifx/danube/config.mk
index e6fcbc6591..e6fcbc6591 100644
--- a/package/uboot-ifxmips/files/board/danube/config.mk
+++ b/package/uboot-ifxmips/files/board/ifx/danube/config.mk
diff --git a/package/uboot-ifxmips/files/board/danube/danube.c b/package/uboot-ifxmips/files/board/ifx/danube/danube.c
index b6174ba6d8..b6174ba6d8 100644
--- a/package/uboot-ifxmips/files/board/danube/danube.c
+++ b/package/uboot-ifxmips/files/board/ifx/danube/danube.c
diff --git a/package/uboot-ifxmips/files/board/danube/ddr_settings.h b/package/uboot-ifxmips/files/board/ifx/danube/ddr_settings.h
index 3a4b1350e4..3a4b1350e4 100644
--- a/package/uboot-ifxmips/files/board/danube/ddr_settings.h
+++ b/package/uboot-ifxmips/files/board/ifx/danube/ddr_settings.h
diff --git a/package/uboot-ifxmips/files/board/danube/ddr_settings_111.h b/package/uboot-ifxmips/files/board/ifx/danube/ddr_settings_111.h
index b655ca2898..b655ca2898 100644
--- a/package/uboot-ifxmips/files/board/danube/ddr_settings_111.h
+++ b/package/uboot-ifxmips/files/board/ifx/danube/ddr_settings_111.h
diff --git a/package/uboot-ifxmips/files/board/danube/ddr_settings_166.h b/package/uboot-ifxmips/files/board/ifx/danube/ddr_settings_166.h
index b655ca2898..b655ca2898 100644
--- a/package/uboot-ifxmips/files/board/danube/ddr_settings_166.h
+++ b/package/uboot-ifxmips/files/board/ifx/danube/ddr_settings_166.h
diff --git a/package/uboot-ifxmips/files/board/danube/ddr_settings_PROMOSDDR400.h b/package/uboot-ifxmips/files/board/ifx/danube/ddr_settings_PROMOSDDR400.h
index 54bb6c9e37..54bb6c9e37 100644
--- a/package/uboot-ifxmips/files/board/danube/ddr_settings_PROMOSDDR400.h
+++ b/package/uboot-ifxmips/files/board/ifx/danube/ddr_settings_PROMOSDDR400.h
diff --git a/package/uboot-ifxmips/files/board/danube/ddr_settings_Samsung_166.h b/package/uboot-ifxmips/files/board/ifx/danube/ddr_settings_Samsung_166.h
index 7975c3ec0d..7975c3ec0d 100644
--- a/package/uboot-ifxmips/files/board/danube/ddr_settings_Samsung_166.h
+++ b/package/uboot-ifxmips/files/board/ifx/danube/ddr_settings_Samsung_166.h
diff --git a/package/uboot-ifxmips/files/board/danube/ddr_settings_e111.h b/package/uboot-ifxmips/files/board/ifx/danube/ddr_settings_e111.h
index b655ca2898..b655ca2898 100644
--- a/package/uboot-ifxmips/files/board/danube/ddr_settings_e111.h
+++ b/package/uboot-ifxmips/files/board/ifx/danube/ddr_settings_e111.h
diff --git a/package/uboot-ifxmips/files/board/danube/ddr_settings_e166.h b/package/uboot-ifxmips/files/board/ifx/danube/ddr_settings_e166.h
index b655ca2898..b655ca2898 100644
--- a/package/uboot-ifxmips/files/board/danube/ddr_settings_e166.h
+++ b/package/uboot-ifxmips/files/board/ifx/danube/ddr_settings_e166.h
diff --git a/package/uboot-ifxmips/files/board/danube/ddr_settings_psc_166.h b/package/uboot-ifxmips/files/board/ifx/danube/ddr_settings_psc_166.h
index 445b7dac1f..445b7dac1f 100644
--- a/package/uboot-ifxmips/files/board/danube/ddr_settings_psc_166.h
+++ b/package/uboot-ifxmips/files/board/ifx/danube/ddr_settings_psc_166.h
diff --git a/package/uboot-ifxmips/files/board/danube/ddr_settings_r111.h b/package/uboot-ifxmips/files/board/ifx/danube/ddr_settings_r111.h
index fd155973ee..fd155973ee 100644
--- a/package/uboot-ifxmips/files/board/danube/ddr_settings_r111.h
+++ b/package/uboot-ifxmips/files/board/ifx/danube/ddr_settings_r111.h
diff --git a/package/uboot-ifxmips/files/board/danube/ddr_settings_r166.h b/package/uboot-ifxmips/files/board/ifx/danube/ddr_settings_r166.h
index 742d34f1d3..742d34f1d3 100644
--- a/package/uboot-ifxmips/files/board/danube/ddr_settings_r166.h
+++ b/package/uboot-ifxmips/files/board/ifx/danube/ddr_settings_r166.h
diff --git a/package/uboot-ifxmips/files/board/danube/flash.c b/package/uboot-ifxmips/files/board/ifx/danube/flash.c
index 587c072d18..587c072d18 100644
--- a/package/uboot-ifxmips/files/board/danube/flash.c
+++ b/package/uboot-ifxmips/files/board/ifx/danube/flash.c
diff --git a/package/uboot-ifxmips/files/board/danube/lowlevel_init.S b/package/uboot-ifxmips/files/board/ifx/danube/lowlevel_init.S
index f5f24a40cf..f5f24a40cf 100644
--- a/package/uboot-ifxmips/files/board/danube/lowlevel_init.S
+++ b/package/uboot-ifxmips/files/board/ifx/danube/lowlevel_init.S
diff --git a/package/uboot-ifxmips/files/board/danube/pmuenable.S b/package/uboot-ifxmips/files/board/ifx/danube/pmuenable.S
index e0d7971d89..e0d7971d89 100644
--- a/package/uboot-ifxmips/files/board/danube/pmuenable.S
+++ b/package/uboot-ifxmips/files/board/ifx/danube/pmuenable.S
diff --git a/package/uboot-ifxmips/files/board/danube/u-boot-bootstrap.lds b/package/uboot-ifxmips/files/board/ifx/danube/u-boot-bootstrap.lds
index 8738ca8a94..36c658b187 100644
--- a/package/uboot-ifxmips/files/board/danube/u-boot-bootstrap.lds
+++ b/package/uboot-ifxmips/files/board/ifx/danube/u-boot-bootstrap.lds
@@ -38,10 +38,10 @@ SECTIONS
}
. = ALIGN(4);
- .rodata : { *(.rodata) }
+ .rodata : { *(.rodata*) }
. = ALIGN(4);
- .data : { *(.data) }
+ .data : { *(.data*) }
. = ALIGN(4);
.sdata : { *(.sdata) }
diff --git a/package/uboot-ifxmips/files/board/danube/u-boot.lds b/package/uboot-ifxmips/files/board/ifx/danube/u-boot.lds
index ad3ec3194e..40645166cb 100644
--- a/package/uboot-ifxmips/files/board/danube/u-boot.lds
+++ b/package/uboot-ifxmips/files/board/ifx/danube/u-boot.lds
@@ -38,10 +38,10 @@ SECTIONS
}
. = ALIGN(4);
- .rodata : { *(.rodata) }
+ .rodata : { *(.rodata*) }
. = ALIGN(4);
- .data : { *(.data) }
+ .data : { *(.data*) }
. = ALIGN(4);
.sdata : { *(.sdata) }