aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/adb/patches/001-create_Makefile.patch
diff options
context:
space:
mode:
authorBjørn Mork <bjorn@mork.no>2019-11-19 14:37:24 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2019-12-23 00:22:07 +0100
commitd034a1f4577108a465e8347d11a51dc0e5a29298 (patch)
tree5784b29aa5f3f900fb17ac716a4a7385e6e3569d /package/utils/adb/patches/001-create_Makefile.patch
parentdd299805ad18472a8245b4524a25e4381e166057 (diff)
downloadupstream-d034a1f4577108a465e8347d11a51dc0e5a29298.tar.gz
upstream-d034a1f4577108a465e8347d11a51dc0e5a29298.tar.bz2
upstream-d034a1f4577108a465e8347d11a51dc0e5a29298.zip
adb: fix for SuperSpeed devices
The USB descriptor parsing in adb fails to detect SuperSpeed devices because of the SuperSpeed Endpoint Companion Descriptor. This cherry-picks the upstream fix for the problem. Unfortunately there never were a release with this fix before the conversion to C++, so upgrading to a newer version isn't an option. This makes adb work with SuperSpeed devices like the Sierra Wireless EM7565. Tested and verified. Signed-off-by: Bjørn Mork <bjorn@mork.no>
Diffstat (limited to 'package/utils/adb/patches/001-create_Makefile.patch')
-rw-r--r--package/utils/adb/patches/001-create_Makefile.patch2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/utils/adb/patches/001-create_Makefile.patch b/package/utils/adb/patches/001-create_Makefile.patch
index be9f5f497a..d7fa00cb4c 100644
--- a/package/utils/adb/patches/001-create_Makefile.patch
+++ b/package/utils/adb/patches/001-create_Makefile.patch
@@ -1,5 +1,5 @@
--- /dev/null
-+++ b/adb/Makefile 2016-10-19 15:28:03.421194137 +0200
++++ b/adb/Makefile
@@ -0,0 +1,42 @@
+SRCS+= adb.c
+SRCS+= adb_auth_host.c