aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/util-linux/Makefile
diff options
context:
space:
mode:
authorDaniel Engberg <daniel.engberg.lists@pyret.net>2017-03-20 09:51:26 +0100
committerFelix Fietkau <nbd@nbd.name>2017-03-22 14:38:48 +0100
commitcf9812dd522ed1a8209478ed62ff243675bd2626 (patch)
tree4745bb695ab6c495924e63dbeb82213414788c9a /package/utils/util-linux/Makefile
parentcfc5b35dd42c7ee633d20d321fbcae3ee9aa7d5e (diff)
downloadupstream-cf9812dd522ed1a8209478ed62ff243675bd2626.tar.gz
upstream-cf9812dd522ed1a8209478ed62ff243675bd2626.tar.bz2
upstream-cf9812dd522ed1a8209478ed62ff243675bd2626.zip
utils/util-linux: Update to 2.29.2
Update util-linux to 2.29.2 Remote 0001-fix-uClibc-ng-scanf-check.patch as it's been merged upstream. Refresh patches Change ncurses to ncursesw to fix compilation and avoid confusion Signed-off-by: Daniel Engberg <daniel.engberg.lists@pyret.net> Signed-off-by: Felix Fietkau <nbd@nbd.name> [remove faulty dependency changes]
Diffstat (limited to 'package/utils/util-linux/Makefile')
-rw-r--r--package/utils/util-linux/Makefile9
1 files changed, 5 insertions, 4 deletions
diff --git a/package/utils/util-linux/Makefile b/package/utils/util-linux/Makefile
index 17f22e1ae4..f85f48e756 100644
--- a/package/utils/util-linux/Makefile
+++ b/package/utils/util-linux/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=util-linux
-PKG_VERSION:=2.28
+PKG_VERSION:=2.29.2
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
-PKG_SOURCE_URL:=@KERNEL/linux/utils/$(PKG_NAME)/v2.28
-PKG_HASH:=395847e2a18a2c317170f238892751e73a57104565344f8644090c8b091014bb
+PKG_SOURCE_URL:=@KERNEL/linux/utils/$(PKG_NAME)/v2.29
+PKG_HASH:=accea4d678209f97f634f40a93b7e9fcad5915d1f4749f6c47bee6bf110fe8e3
PKG_LICENSE:=GPL-2.0
PKG_LICENSE_FILES:= COPYING \
@@ -440,7 +440,8 @@ CONFIGURE_ARGS += \
--without-python \
--without-udev \
--without-readline \
- $(if $(CONFIG_PACKAGE_cal)$(CONFIG_PACKAGE_cfdisk)$(CONFIG_PACKAGE_setterm),--with-ncurses,--without-ncurses)
+ --disable-more \
+ $(if $(CONFIG_PACKAGE_cal)$(CONFIG_PACKAGE_cfdisk)$(CONFIG_PACKAGE_setterm),--with-ncursesw,--without-ncurses)
TARGET_CFLAGS += $(FPIC) -std=gnu99