aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/util-linux/Makefile
diff options
context:
space:
mode:
authorDaniel Engberg <daniel.engberg.lists@pyret.net>2017-03-20 09:51:26 +0100
committerJohn Crispin <john@phrozen.org>2017-03-22 09:16:23 +0100
commiteac1a548573a0262e9f36aeee95ed071f6040703 (patch)
treece21918f25a236e910b12f9011775edca6dc053c /package/utils/util-linux/Makefile
parent480a6aec98f005a6102ba35bead7c6d008212a9a (diff)
downloadupstream-eac1a548573a0262e9f36aeee95ed071f6040703.tar.gz
upstream-eac1a548573a0262e9f36aeee95ed071f6040703.tar.bz2
upstream-eac1a548573a0262e9f36aeee95ed071f6040703.zip
utils/util-linux: Update to 2.29.2
Update util-linux to 2.29.2 Remote 0001-fix-uClibc-ng-scanf-check.patch as it's been merged upstream. Refresh patches Change ncurses to ncursesw to fix compilation and avoid confusion Signed-off-by: Daniel Engberg <daniel.engberg.lists@pyret.net>
Diffstat (limited to 'package/utils/util-linux/Makefile')
-rw-r--r--package/utils/util-linux/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/package/utils/util-linux/Makefile b/package/utils/util-linux/Makefile
index 17f22e1ae4..fc1554bef8 100644
--- a/package/utils/util-linux/Makefile
+++ b/package/utils/util-linux/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=util-linux
-PKG_VERSION:=2.28
+PKG_VERSION:=2.29.2
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
-PKG_SOURCE_URL:=@KERNEL/linux/utils/$(PKG_NAME)/v2.28
-PKG_HASH:=395847e2a18a2c317170f238892751e73a57104565344f8644090c8b091014bb
+PKG_SOURCE_URL:=@KERNEL/linux/utils/$(PKG_NAME)/v2.29
+PKG_HASH:=accea4d678209f97f634f40a93b7e9fcad5915d1f4749f6c47bee6bf110fe8e3
PKG_LICENSE:=GPL-2.0
PKG_LICENSE_FILES:= COPYING \
@@ -147,7 +147,7 @@ endef
define Package/cal
$(call Package/util-linux/Default)
TITLE:=display a calendar
- DEPENDS:= +libncurses
+ DEPENDS:= +libncursesw
endef
define Package/cal/description
@@ -157,7 +157,7 @@ endef
define Package/cfdisk
$(call Package/util-linux/Default)
TITLE:=display or manipulate disk partition table
- DEPENDS:= +libblkid +libncurses +libsmartcols +libfdisk +libmount
+ DEPENDS:= +libblkid +libncursesw +libsmartcols +libfdisk +libmount
SUBMENU:=Disc
endef
@@ -341,7 +341,7 @@ endef
define Package/setterm
$(call Package/util-linux/Default)
TITLE:=set terminal attributes
- DEPENDS:= +libncurses
+ DEPENDS:= +libncursesw
SUBMENU:=Terminal
endef
@@ -440,7 +440,7 @@ CONFIGURE_ARGS += \
--without-python \
--without-udev \
--without-readline \
- $(if $(CONFIG_PACKAGE_cal)$(CONFIG_PACKAGE_cfdisk)$(CONFIG_PACKAGE_setterm),--with-ncurses,--without-ncurses)
+ $(if $(CONFIG_PACKAGE_cal)$(CONFIG_PACKAGE_cfdisk)$(CONFIG_PACKAGE_setterm),--with-ncursesw,--without-ncurses)
TARGET_CFLAGS += $(FPIC) -std=gnu99