aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorStefan Oberhumer <stefan@obssys.com>2017-05-31 07:37:03 +0200
committerFelix Fietkau <nbd@nbd.name>2017-10-24 13:24:04 +0200
commit06e41056aab12f5fb6c35789d0bde71bcf1dc90e (patch)
tree1f4244cd2b3780395fb12c520175e3220cb376ea /package
parentf28b3bb56af4cb870f5b9b8a6e5bd0b3021de837 (diff)
downloadupstream-06e41056aab12f5fb6c35789d0bde71bcf1dc90e.tar.gz
upstream-06e41056aab12f5fb6c35789d0bde71bcf1dc90e.tar.bz2
upstream-06e41056aab12f5fb6c35789d0bde71bcf1dc90e.zip
libs/lzo: Reenable unaligned access on ARM, PPC, ...
Due a compiler bug on ARM targets ( https://gcc.gnu.org/bugzilla/show_bug.cgi?id=64516 ) unaligned access was disabled on all targets other than i386 and x86_64 with commit 061319ec3dfe9b6d14af1286a1d9979db56048d7 . A fix has been added to lzo-2.09 so it is not necessary to disable unaligned access within the Makefile anymore. Signed-off-by: Stefan Oberhumer <stefan@obssys.com>
Diffstat (limited to 'package')
-rw-r--r--package/libs/lzo/Makefile4
1 files changed, 0 insertions, 4 deletions
diff --git a/package/libs/lzo/Makefile b/package/libs/lzo/Makefile
index 8d85e4652e..ef33619d88 100644
--- a/package/libs/lzo/Makefile
+++ b/package/libs/lzo/Makefile
@@ -42,10 +42,6 @@ CONFIGURE_ARGS += \
TARGET_CFLAGS += $(FPIC)
MAKE_FLAGS += CFLAGS_O="$(TARGET_CFLAGS)"
-ifeq ($(CONFIG_i386)$(CONFIG_x86_64),)
- TARGET_CFLAGS += -DLZO_CFG_NO_UNALIGNED=1
-endif
-
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/include/lzo $(1)/usr/include/