aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorSteven Barth <cyrus@openwrt.org>2013-01-13 18:06:24 +0000
committerSteven Barth <cyrus@openwrt.org>2013-01-13 18:06:24 +0000
commit0cd21ca7859500f7045013dfecba9427c5f0b22a (patch)
tree64a9163461cd988cf99b8eee5f616607523fd907 /package
parentf0df2006af4b7d365c313f6028addc80467cb10f (diff)
downloadupstream-0cd21ca7859500f7045013dfecba9427c5f0b22a.tar.gz
upstream-0cd21ca7859500f7045013dfecba9427c5f0b22a.tar.bz2
upstream-0cd21ca7859500f7045013dfecba9427c5f0b22a.zip
odhcp6c: Send RS on start
SVN-Revision: 35137
Diffstat (limited to 'package')
-rw-r--r--package/network/ipv6/odhcp6c/Makefile2
-rwxr-xr-xpackage/network/ipv6/odhcp6c/files/dhcpv6.script3
2 files changed, 4 insertions, 1 deletions
diff --git a/package/network/ipv6/odhcp6c/Makefile b/package/network/ipv6/odhcp6c/Makefile
index f97e6ac2ac..1a3296d36c 100644
--- a/package/network/ipv6/odhcp6c/Makefile
+++ b/package/network/ipv6/odhcp6c/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=odhcp6c
-PKG_VERSION:=2013-01-11
+PKG_VERSION:=2013-01-13
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
diff --git a/package/network/ipv6/odhcp6c/files/dhcpv6.script b/package/network/ipv6/odhcp6c/files/dhcpv6.script
index 8f258f5c37..859ae1b745 100755
--- a/package/network/ipv6/odhcp6c/files/dhcpv6.script
+++ b/package/network/ipv6/odhcp6c/files/dhcpv6.script
@@ -19,6 +19,9 @@ prepare_interface() {
ipv6_conf "$device" accept_ra 2
ipv6_conf "$device" forwarding 2
+
+ # Send RS
+ [ -x /usr/sbin/6relayd ] && /usr/sbin/6relayd -s "$device"
}
cleanup_interface() {