aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2011-06-12 19:27:21 +0000
committerJo-Philipp Wich <jow@openwrt.org>2011-06-12 19:27:21 +0000
commit1277bd7186b70f096a607cb64865f02bf0457c57 (patch)
tree24411a636ae2742e90c4e88a96074042e3dc9eed /package
parent6a5112a75054f4315c5042dcb83837dc35e0c488 (diff)
downloadupstream-1277bd7186b70f096a607cb64865f02bf0457c57.tar.gz
upstream-1277bd7186b70f096a607cb64865f02bf0457c57.tar.bz2
upstream-1277bd7186b70f096a607cb64865f02bf0457c57.zip
6to4: advertise effective tunnel mtu in RAs
SVN-Revision: 27163
Diffstat (limited to 'package')
-rw-r--r--package/6to4/Makefile4
-rwxr-xr-xpackage/6to4/files/6to4.sh9
2 files changed, 7 insertions, 6 deletions
diff --git a/package/6to4/Makefile b/package/6to4/Makefile
index a6f3315a4a..77082a4a04 100644
--- a/package/6to4/Makefile
+++ b/package/6to4/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2010 OpenWrt.org
+# Copyright (C) 2010-2011 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=6to4
-PKG_VERSION:=4
+PKG_VERSION:=5
PKG_RELEASE:=1
include $(INCLUDE_DIR)/package.mk
diff --git a/package/6to4/files/6to4.sh b/package/6to4/files/6to4.sh
index 6e85914b43..b8baa1510d 100755
--- a/package/6to4/files/6to4.sh
+++ b/package/6to4/files/6to4.sh
@@ -30,6 +30,7 @@ test_6to4_rfc1918()
set_6to4_radvd_interface() {
local cfgid="$1"
local lanif="${2:-lan}"
+ local ifmtu="${3:-1280}"
local ifsection=""
find_ifsection() {
@@ -55,6 +56,7 @@ set_6to4_radvd_interface() {
uci_set_state radvd "$ifsection" IgnoreIfMissing 1
uci_set_state radvd "$ifsection" AdvSendAdvert 1
uci_set_state radvd "$ifsection" MaxRtrAdvInterval 30
+ uci_set_state radvd "$ifsection" AdvLinkMTU "$ifmtu"
}
set_6to4_radvd_prefix() {
@@ -203,7 +205,7 @@ setup_interface_6to4() {
logger -t "$link" " * Advertising IPv6 subnet $subnet6 on ${adv_interface:-lan} ($adv_ifname)"
ip -6 addr add $subnet6 dev $adv_ifname
- set_6to4_radvd_interface "$sid" "$adv_interface"
+ set_6to4_radvd_interface "$sid" "$adv_interface" "$mtu"
set_6to4_radvd_prefix "$sid" "$adv_interface" \
"$wancfg" "$(printf "0:0:0:%x::/64" $adv_subnet)"
@@ -252,9 +254,8 @@ stop_interface_6to4() {
done
}
- [ "$defaultroute" = "1" ] && {
- ip -6 route del ::/0 via ::192.88.99.1 dev $link metric 1
- }
+ [ "$defaultroute" = "1" ] && \
+ ip -6 route del ::/0 via ::192.88.99.1 dev $link
ip addr del $local6 dev $link
ip link set $link down