aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2009-09-25 14:10:42 +0000
committerFelix Fietkau <nbd@openwrt.org>2009-09-25 14:10:42 +0000
commit1b35350431fe741f60b15144ac398d241bea1a5d (patch)
treec67ab47560b6e639b5039b189ff94f62828c6927 /package
parenta2f344ec8496c8641e97e41e825f3bd464a45a6c (diff)
downloadupstream-1b35350431fe741f60b15144ac398d241bea1a5d.tar.gz
upstream-1b35350431fe741f60b15144ac398d241bea1a5d.tar.bz2
upstream-1b35350431fe741f60b15144ac398d241bea1a5d.zip
iptables: fix build error with linux 2.6.31
SVN-Revision: 17721
Diffstat (limited to 'package')
-rw-r--r--package/iptables/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/package/iptables/Makefile b/package/iptables/Makefile
index 818e686d47..b8164458ee 100644
--- a/package/iptables/Makefile
+++ b/package/iptables/Makefile
@@ -247,7 +247,11 @@ define Package/libxtables
endef
-TARGET_CPPFLAGS := -I$(PKG_BUILD_DIR)/include $(TARGET_CPPFLAGS)
+TARGET_CPPFLAGS := \
+ -I$(PKG_BUILD_DIR)/include \
+ -I$(LINUX_DIR)/arch/$(LINUX_KARCH)/include \
+ $(TARGET_CPPFLAGS)
+
TARGET_CFLAGS += $(FPIC)
CONFIGURE_ARGS += \
--enable-shared \