aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
authorAlexandros C. Couloumbis <alex@ozo.com>2010-07-06 11:17:41 +0000
committerAlexandros C. Couloumbis <alex@ozo.com>2010-07-06 11:17:41 +0000
commit1f10f64d62f59d0a72ade8dee424404e93fa5489 (patch)
tree150df8143aad39f20e475aa9d07d801bd24829ed /package
parenteccba67e0a96c40cac84906b6e4a4f370c9c1ff0 (diff)
downloadupstream-1f10f64d62f59d0a72ade8dee424404e93fa5489.tar.gz
upstream-1f10f64d62f59d0a72ade8dee424404e93fa5489.tar.bz2
upstream-1f10f64d62f59d0a72ade8dee424404e93fa5489.zip
package/busybox: fix sed issue with gcc-4.5.0 (closes #7566)
SVN-Revision: 22074
Diffstat (limited to 'package')
-rw-r--r--package/busybox/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/busybox/Makefile b/package/busybox/Makefile
index aa51b17c8d..128a0dea18 100644
--- a/package/busybox/Makefile
+++ b/package/busybox/Makefile
@@ -60,6 +60,10 @@ ifdef CONFIG_GCC_VERSION_LLVM
TARGET_CFLAGS += -fnested-functions
endif
+ifdef CONFIG_GCC_VERSION_4_5_0
+ TARGET_CFLAGS += -fno-tree-pta
+endif
+
define Build/Compile
$(MAKE) -C $(PKG_BUILD_DIR) \
CC="$(TARGET_CC)" \